FAT file corrupted

Please help. I just got a 2 gb Fuze for christmas and its been great. today when I turned it on, it says FAT file corrupted, plug into comp to fix. When I do, nothing happens. Fuze charges, but nothing happens to fix the prob.  Thanks

Either return this product or try to see if you can access this device from Rhapsody and try to right-click to “format” it deleting everything on your fuze giving you a fresh new start. You can go try to install the firmware and see how that works. Tell me how it goes.


Try resetting the device by holding the power switch in the ON position for 15 seconds, and release.  See if it will start up normally.

Did you connect your Fuze in MSC or MTP mode? 

Open a Windows Explorer window via My Computer or [Windows Key] +E.

For this repair, let’s manually ensure MSC mode.  Starting with the Fuze OFF, slide the power switch down to the HOLD / LOCK position (orange showing).  Press and hold the << button down while plugging in to the computer.

Does the Fuze appear in the Explorer window as two drives?  Make a note of the first drive listed alphabetically.  This is the internal memory of your Fuze.

Let’s look for a corrupted file using the chkdsk  utility.  Go to the Run box.  Start > Run > type cmd [enter].  An MSDOS command prompt will now be available in a window.  Cool.  Old school.

Now, using the drive letter you found in the previous step, let’s assume it’s E: for this example, enter:

chkdsk e: /f

Press the [enter] key, and let the utility have a go at your internal memory.  The /f part is a toggle, telling chkdsk to “fix” the errors found.  When chkdsk asks you if you would like to save the errors as files, say no.

Now that our task is done, click on the "safely remove hardware icon in the system tray, and unplug.

The Fuze will refresh its database, and let us know if you are back in business!

Bob  :smileyvery-happy:

Bob -

I tried what you suggested, and received the following:

The type of file system is RAW.

CHKDSK is not available for RAW drives.

This is for a 8gb Fuze.

Any suggestions?



You will need to perform an MSC format to recover the unit.

Right click the device and format it from the computer. then after you disconnect, you need to reformat from the settings menu to get the optimal cluster size.

Any way at all to recover the data?  Are the Voice recording stored here also?


@curiousemail wrote:

Any way at all to recover the data?  Are the Voice recording stored here also?



No, if you have to format, everything you’ve loaded on the player will be erased.

Found a way to recover ALL Data before formatting.  Years ago I had purchased Get Back Data (FAT 32) from http://www.runtime.org/data-recovery-downloads.htm

I installed the software, pointed it to the drive, and after it read and diganosed everything (about 25 minutes), I was able to copy EVERYTHING to my local drive.

In case anyone runs across this, it worked great.

Thanks for everyone’s help today.  Hope this helps others too.


Ok i’ve got the same problem so i downloaded the program but can’t quite seem to figure out how to point it to an external drive. Help me pls. 

I’m a newbie to the forum,been checking things out.Today i really needed you guys.I have a 4gb Red Fuze w/8gb micro sd.I had the same problem as tigger5413 did. Fat is corrupted.I remembered that mine was set in the msc mode so i did what sansafix said to do and thanks to him and everyone else who posted replies i’m back up and running again.


Help !  When I plug my clip into the USB - the computer doesn’t even see it!

I am using a MAC.  When I tried to return the device, it was past the 30 days.  The Geek Squad got it to work at the store and thought I needed to upgrade my operating system.  My son plugged in the clip to charge it on the MAC and it worked (before upgrading)!  He was so excited- he loaded about 20 songs and bebopped thru the house - then WHAM!!!  Everything’s gone and it says FAT Corrupted plug into pc .  The computer doesn’t see it.  Any suggestions??? 

I have read your fix and tried using both sollutions but when I connect my fuze 8mb to my computer shows it scanning and the fuze screen shows its connected but my computer does not show it on the explorer  where it normally would. Nor does it show in rhapsody like it normally would. My fuze got disconnected during a rhapsody update session.

Any suggestions. Thanks

Go to Settings/USB Mode and switch to MSC. It should show up as two drives in Explorer.

Bob, I tried everything you have said.

I have also tried reformatting the fuze and using the download.

but still, nothing is working.

my fuze still says “FAT file corrupted” and says that I must fix the fat file to use my fuze.

I also have the same problem as jason, which I have listed below.

"Bob -

I tried what you suggested, and received the following:

The type of file system is RAW.

CHKDSK is not available for RAW drives.

This is for a 8gb Fuze."

Can anyone please help?

Push the power slider to to down(locked) position. Hold down the center button while connecting the player to the pc. Keep holding the button until the player is recognized. This forces the player to connect in MSC mode. Next format the player using the pc. I am assuming you have copies of everything on the player on your pc, as formatting the player will delete all the songs on it. 

 When that is done, unplug the player, and it should boot properly. Set the USB mode on the player to MSC. Reformat the player using the player’s menu. After that, you can connect the player to the pc and reload your songs.

Take a look at this.


Perhaps, you can try formatting the device as FAT32 from Windows?

It erases all of your media from teh device, but all you’ll need do is reload your music.  Formatting does not affect the operating system / firmware area of the Sansa’s memory.

Bob  :wink:

i hope someone is watching this but i’m almost going to cry!

i love my fuze but today i turned it on and the screen was white… i tried to put on new firmeware but it didn’t work… after charging the screen worked but now it showes me “fat is corrupted” and nothing else! and my pc doesn’t recognize it…

i tried the things you told here but they are also not working… :[ 

Try connecting in MSC mode and using the chkdsk utility from your PC.

If you right click on My Computer, this is available be selecting manage , then look for Disk Management under Storage.  Highlight the Fuze, or double click on it, then select Check Disk For Errors under the Tools tab.

If you use chkdsk, first find the drive letter assigned to the Fuze (have a look at the Fuze using the Windows Explorer window.  For this example, let’s assume it’s drive E.  The command will be chkdsk e: /f where the /f command is a toggle, telling the utility to fix the errors.

Bob  :smileyvery-happy:

but the problem is that it’s not shown up…

my pc just doesn’t recognize it…