Express won't recognize on USB port :(

I’ve had the Express now since Christmas, and it’s been working fine. Even bought a 2GB microSD card and been using that with no problems.

A few days ago I noticed it was really low on battery power. Today I tried to plug it in to my PC to charge it, and it said:

“USB device not recognized.
One of the USB devices attached to this computer has malfunctioned…”

The battery was almost completely dead. I left it plugged into the PC for an hour or so. The battery bar reads full now, and music plays like normal.

But when I plugged it into the PC it still says the device is malfunctioning, like above.

So I set Device Manager to show all nonpresent devices, deleted the device, and plugged it back in, so it would reinstall and everything. Here is what happened:

“Found new Hardware: USB device”


“Your hardware is installed and ready to use.”

But then:

“USB device not recognized.
One of the USB devices attached to this computer has malfunctioned…”


So tried it on another PC that I’ve never used it before. Same thing. Tried it on different USB ports. Same thing. Even tried hard resetting, using the select and the volume + button. Still nothing.

Anyone had this problem?? I can play music but I can’t add any files like this Really sux. Worked perfectly until now.

I have the situation. It’s really annoying!

Anybody can help?


I just got a Sansa Express…not had it 24hrs yet and already I’m having the same problem…USB port won’t recognise it! Help!!!

You could try reflashing your device by doing the following:

(1)  While holding down the Volume Down (-) button, connect the device to your computer.
(2)  If a “Found New Hardware” window appears for an STMP3600, let Windows connect to the Internet to find the “Player Recovery Class” driver automatically.
(3)  Run the firmware update utility for the Sansa Express.  (This will delete everything.)

Performing step 1 should get your device recognized as an STMP3600, rather than a Sansa Express.  If you can’t get your device recognized as an STMP3600, then you probably have a hardware problem and must return the device for a refund/replacement.

Thank You :womanvery-happy:

I have exactly the same problem and I’ve about had enough of it!

I’ve tried soft-resetting it and attaching in MSC mode, but it simply will not even turn on or be recognized when attached – until I let go of the “-” key, at which point I get the “USB device not recognized” error. I have had the exact same issue on two completely different computers.

The Express worked fine for 2-3 weeks and now this. I’ve tried everything that I can find online to get the player to work. The flash update utility won’t work since it can’t “see” the player attached inany mode. I’m at a loss as to what to try at this point since Windows does not seem to want to recognize the player no matter what I do.

If anyone out there has ideas on how to fix this, I would love to hear them. Thanks!

I faced same problem but it start working after installation of windows media player 11 and sp3 of XP