Error with video files

Hello,

Did a speed browse of the topics, and didn’t found similar problems, so I thought I’d post it here.

So my thumb drive is Sandisk Cruzer Blade 16GB. Found that it came with bundled Secure Access, so I thought, oh yeah, nice move sandisk. So I copied + encrypted a few video files, MP4 and AVI from my old work PC, low level format the old HDD, and got rid of the old PC.

The videos are important documentation/projects on the company I work for. It’s important not to be lost, and it’s important not to be released to the public. 

So brought it home to my home PC, tested all the vid files, everything was OK. I waited for the new office PC to be ready. When it’s ready, plugged it to the new PC, and a lot of the files were corrupted. As it’s AVI (streaming), I can still watch a portion of the video, and then the media player would hang. For example, say the video is 3 minutes long. I can still watch 1 minute normally, but then it hangs. 

Initially, I thought it might be the new PCs video player codec, so I downloaded every codec I could get my hand on, and various media players, no success. Then I tried plugging it to another department’s PC that I know for sure was working for the video files, and I got the same problem. So it’s not codec problem then, it’s the secure access’ problem. 

I guess the question is, is there any hope of repairing the corrupt files, considering media players still recognize them, and still playing them, albeit just a portion of it. Or is it lost for good?

RMA would be of no use, as it’s the data inside that counts. 

You should try to use the flash drive again at your home PC since the files played properly there. This way we would be able to isolate if the problem is with the Vault or the Computer

Also, try to drag and drop the video to your Desktop and then play them. If they dont, the files might be corrupted. Unfortunately if a file inside an encrypted folder get corrupted, recovery of data using data recovery software is not possible.