e280 hangs on startup, will not reset, will not update firmware

I have had a lot of problems with my v1 e280. I’ve tried a lot of different firmwares. The last one is e200fw01.03.01beta and it worked for a couple of months, but now it hangs on startup and nothing i do makes any difference. Is there a way to remove the firmware. I’ve tried recovery mode with the latest firmware, but it just doesn’t take. I know it might take a couple of tries, but 17? Usually there is a “last resort” thingy on devices like this, but I can’t find it anywhere. Please help!

If this has been answered before please point me in the right direction.

Ah, the dreaded Hebrew Beta firmware!

Go to anythingbutipod.com, and search for “Hebrew Beta”.  There is a thread there with the instructions on how to restore your Sansa to normal operation.  The problem is that some files are renamed in the Beta firmware, making removal a pain.

The thread there explains the process in detail.

One change I would recommend is to download a copy of firmware 1.02.18 or 1.02.24 from the SanDisk website, rather than from a third party source.  Both firmware libraries are available here.

Once the files are properly renamed, you can load the original firmware.

I do like the Lil Monsta though.  It’s more important to have a running Sansa.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 10-13-2008 01:29 PM

Thank you so much for the quick reply :smiley:. I will try this tomorrow and let you know how it went.

Piece of cake!

Found this thread:  http://www.anythingbutipod.com/forum/showthread.php?t=7487

Very easy and worked perfectly.

Thanx for pointing me in the right direction.

Hi Neutron Bob!

Apparently you have all the answers… 

I have a m240 1GB that works perfectly ok, but when I want to delete old programs It hangs on the PC. 

I need some help. 

  1. I d’ont know how to reset It. 

  2. If I reset It and lose firmaware, I d’ont know where to find IT and how to install It again. 

My m240 is old and small but is perfect for me and I love It.

Thanks in advance for your help. 

Did you check the Sansa m200 series board?

The latest firmware is there, as well as the instructions on how to install it. I’ll even bet if you looked around for 5 minutes or less (maybe even use the Search function), you’d find the reset procedure too. :wink:

I tried every reset procedure on the 200 series forum. Even disamble my clip and remove the memory card (there is a procedure that worked for 2 people with a m250). The corrupted files are still there…First thing I used was the search function.

I cannot connect the device to the pc cause it hang ti on. The properties/tools etc. procedure doesn’t work either.

I tried lock, hold the record button, turn it on. My m240 works perfectly but I can’t erase any file. 

 Do you have any idea of how to reset it without connect it to the pc? I have it in parts yet…

Thanks !

The cool little m-series machine will respond best if you format the device, then reload your music.  Just be sure you have backup copies of your music, a wise policy regardless of the portable machine used.

Don’t feel bad about it, I format the e200 every now and again, as well as the Fuze.  A “clean sweep” is nice every now and again.  Sometimes, the older files get lost in the index, even though you can find them on the device itself.

Are you using the machine with Rhapsody?  If using a subscription service, be sure to reauthorize the device after formatting.

Bob  :smileyvery-happy:

Hi and thanks for your response Bob!

The problem is that I cannot connect the clip to the pc because it hung it on. So I tried the reset procedure from the m240, it doesn’t work. I even disambled the m240 remove the memory card, as in the procedure explain in the m200 series forum. Nothing… Correupted files are still there… Do you know any procedure to format the device, without connect it to the pc?

Thanks again!