e260 Frozen

Hi Sandisk Community. I recently bought a refurbished e260 v2 for my daughters birthday. My 5 yo son got to it and somehow has frozen it up so that all you get is the menu screen but that’s where it stays. I have read all the forums here and believe I need to reinstall the firmware. I am having trouble doing this. Sansa Updater does not work and not being tech savvy have trouble with the manual guide to doing this. I cannot even get the unit into recovery mode by locking device and holding Rec button. I have also tried the soft reset by holding the start button and have also tried removing battery. I really like the sansa and have had an e280 for a couple of years so I’m keen to fix.

Hope someone can help

@russo wrote:

Hi Sandisk Community. I recently bought a refurbished e260 v2 for my daughters birthday. My 5 yo son got to it and somehow has frozen it up so that all you get is the menu screen but that’s where it stays. I have read all the forums here and believe I need to reinstall the firmware. I am having trouble doing this. Sansa Updater does not work and not being tech savvy have trouble with the manual guide to doing this. I cannot even get the unit into recovery mode by locking device and holding Rec button. I have also tried the soft reset by holding the start button and have also tried removing battery. I really like the sansa and have had an e280 for a couple of years so I’m keen to fix.

 

Hope someone can help

You can’t get into Recovery Mode because v2’s do not have a Recovery Mode. The manual install directions are quite simple. Download and extract the firmware .zip file. Connect by forcing MSC mode (HOLD swith on,holding REW |<< button while plugging into computer) and dragging extracted firmware file to the e260. Un-plug, slide HOLD switch off and let it do it’s thing.

You can get the latest firmware version (and more detailed installation directions) here.

Thanks Tapeworm. I was trying to push the record button on the side rather than the rewind. Also, I am in Australia, so which version of firmware do I need, Americas or Europe? Sorry to ask basic questions.

Pressing the REC button whle connecting with the HOLD switch on is the proper procedure for entering Recovery Mode, but since your player does not have this then that won’t help (as I explained earlier).

As far as which firmware? Hmmm . . . I guess you could go either way, living ‘down under’. I’d probably try the American version, since you’re unlikely to need any of the Europen language support that may be included in the European version.

You can always re-load the other if need be. :smiley:

Pressing the REC button whle connecting with the HOLD switch on is the proper procedure for entering Recovery Mode, but since your player does not have this then that won’t help (as I explained earlier).

As far as which firmware? Hmmm . . . I guess you could go either way, lving ‘down under’. I’d probably try the American version, since you’re unlikely to need any of the Europen language support that may be included in the European version.

You can always re-load the other if need be. :smiley:

I have successfully Updated Firmware as described and it seemed to update the firmware. Once I switch it back on it says Refresh Database and then goes to the screen to select language. It then sticks on this screen and I cant do anything else, scroll wheel wont work and none of the buttons respond.