M240 stuck on startup screen

I can power it up and turn it off but that’s all it will do.

V4.0.44a firmware, it’s not visible to my PC so I can’t upgrade the firmware.  Is there a reset feature somewhere?  Tried new batteries already.   Less then 1 year old.

your going to have to email sandisk support, your player is probably gonna get replaced. I read somewhere that there was a huge problem with version 4 firmware, and it freezing up. That was prior to the update they have on their site now anyway.

There is a Reset All for the settings of the player under settings on the player.
Have you tired rebooting? Then look for the M240 under My Computer.
What mode are you in?

Which Version 4? Am I OK with the latest?
Where’s the update?

the one previous to the latest was the buggy one. there was only 2 ever available.

Message Edited by Enigma on 09-04-2007 07:10 PM

I had the exakt same problem with my 1 GB m240 after uploading 800 new small mp3s and having it run out on battery while “rebuilding the library” as it sais. I thought it was doomed but I managed to start it again.This is how:

  1. I plucked the battery out overnight (can probably be skipped)
  2. Plugged in the usb connection and let it sit, it locked at the startup screen as usual
  3. Waithed 10min+
  4. Voila! The computer beeped and it had found it!
  5. Removed the files (just to be sure)
  6. Put one file in
  7. Pulled the usb out and it worked again!

If it works for you, I am happy to have helped.

If not, you could check this thread as well:
http://www.mobileplanet.com/ft.aspx?k=81396&page=1

same thing happened to me a couple of days ago too, also owned for less than a year and rarely used.  I have just emailed Sansa support.  Hope to hear a solution.

I am rather disappointed in my new purchase. I have had my 2 players for less than 2 weeks (gifts for my girls) and the frozen screen of death happens on one of them. Tried the suggestions but it looks as though I will have to get a replacement. If this is a common occurrence it should have been rectified a while ago. I hope someone from support is reading the forums and has our interests at heart. Please keep us posted with any solution.

there is a fix for it, update on the firmware. The first version of the 4 firmware had issues, so they put out an update thats available on the website. Unfortunately once its frozen though, you cant update. So be sure to update as soon as you can

Yeah, thanks Enigma. I will update my other player as a precaution. I do feel however that it should be made common knowledge to other prospective buyers of older versions. eh?

how would you suggest spreading the word besides posting it online. If people call they would get the same result… and the boxes are already on the shelves. Seems like quite a dilema

No dillema Enigma, Sandisk need to be proactive with their dealers. Either pull the stock and replace it or put stickers on the packaging saying…blah blah blah! Service is paramount when you are a major supplier. I liken the situation to buying a  new TV, taking it home and finding you can’t change channels. They know the problem exists and therein lies the apathy. It’s almost deceitful.

but theres no way of telling which is which when it is in the boxes. SanDisk has 4 different types of firmware all starting with 1,2,3,4 respectfully. There is no way to know which firmware is on the box without opening it, turning it on and seeing.

Im sure its easier as a company to deal with it on a case by case basis rather then recall, or telling the retailers to sticker all the packages telling customers to upgrade the firmware.

I think your example is a little drastic, but you have a point to a degree. Anyone who cares enough to check the website will see that an upgrade is needed, thats a plus.

Yes I am being a bit over zealous but it is annoying. Anyway, I went to update my firmware on the second player and guess what? Doh! It froze on me. Like a dog when you take it to the vets, they know! So now I have 2 brand new dead mp3 players. Looks like 2 replacements.

lol @ dogs to the vet.

Well atleast now you know about the firmware update to be made. Although I doubt they go through the effort of ensuring the customer gets the same firmware player back on the m200s. If you replace it, theres no 100% chance of you getting a player with version 4 firmware anyway, so you might just bypass the issue that way.

Are you in MSC mode when trying to update Firmware? If not it will
stick on the screen saying " Warning, do not disconnect,etc."
Make sure you have the player set to MSC mode under Settings,
USB.

Thanks for the tip Paul. I never got as far as downloading the update! I am sure there are a lot more tips I will be needing in future. As soon as I get my players replaced I will update them. And yes you are probably right on the button Enigma.
                                     

Message Edited by olly on 09-13-2007 01:53 PM

Hi

I just had to add my thoughts regarding the defective firmware. I have exactly the same problem and purchased my sansa m240 one year and 5 months ago. So that means it’s out of warranty and Sansa will not replace it. While I agree that it would be difficult for SanDisk to notify buyers of the defective firmware, I firmly beleive that in this case they should extend the warranty period for the defective players. Most people are not going to be looking at the Sansa boards UNLESS and UNTIL they have a problem. If that happens to be 1 year and 1 day after their purchase, too bad for them according to SanDisk. Well, for my part I won’t buy another SanDisk product again.

Thanks for the opportunity to vent! :smiley:

if you have the product for 1 year+ without it crashing then I think I’ve gotten my 30-40 dollars worth. This is a cheapo deapo player. A decent alternative for someone new to the mp3 world, looking to jump aboard.

Besides, if the firmware was the version 4 one that had issues, it will fail way before a years time.

my m240 froze up after a couple of months, and I got it RMA’d in September (2007).   My replacement did NOT have the ‘latest’ firmware, at least according to the firmware post at the beginning of the forum board.   My replacement had 4.0.45a, the forum board says the newest is 4.1.08.    That message said it was editted on 7/19/2007, so it seems I should have gotten the newest firmware with my replacement, especially if the newest firmware prevents or eliminates the ‘freeze up’ issue.  

ALSO, I have seen somewhere on the Sandisk site that you CANNOT update your firmware for you m240 if you have version 4.x.x    (unfortunately I can’t find that webpage at the moment, so I can’t provide the link  that proves it)   

To be fair, my initial RMA experience was very painless.    However, I can’t go through this every couple of months, trying to get another RMA.   I understand the m240 was a low-end player (translation: cheap), but I would still expect to get more than 2 or 3 months out of the thing.  

Aha, a little more digging, and I found where it says the players with 4.x.x firmware can’t be updated:     http://www.sandisk.com/Retail/Default.aspx?CatID=1326

Again, I am understanding - things break, bad products get put out, etc.    But in my case, Sandisk had the chance to make it right (if the firmware 4.1.08 upgrade can resolve this), but didn’t.    I will try another RMA, but if they can’t get a low end product right, why would I ever consider a higher-end product from them?