Actual Solution to M250 "freezing" problem?

I’ve encountered the same notorious issue as other M250 owners.  I loaded 100+ songs on to my player and now it gets stuck on the “Sansa m250” screen.  I’ve owned the player for 10 months now; it has worked flawlessly and I have updated the firmware prior to the freezing issue.

That being said I’ve researched the web, tried any suggested fixes (including the “reset and leave out the battery” recommendation,) all of which have failed to revive the player.  In addition, I have emailed tech support and have not received a response (over 72 hours.)

Has anyone actually solved this problem without either returning or RMA’ing the player?

Thanks!

what email address did you contact support at?

I used the “North America Technical Support” link off the Sandisk website. 

https://www.customernation.com/pls/ps/ps.ps_main?p_host=304&p_supplier=5096&p_parm=PSHPP

Thanks!

Have you tried this:  take out the battery and connect the player to your PC as usual.  See if the player is recognized (in MSC mode) by the PC.  You can then try to format the player.

I hooked it up and left it for 30 mins.  It stays stuck on the “Sandisk Initializing” screen. 

Pomufc,

I’ve got the EXACT same problem.  It was working flawlessly for about 10 months also, then it locks up.  I also emailed Tech Support and never got a response.

I don’t know any fixes, but I’m still looking.  I’m going to try and email tech support once again.

The only way I can turn the player off is by removing the battery.  When I hook it up with or without the battery, it locks on the menu screen.

What the?

Sorry for not updating…

Tech Support got back to me on my second request.  They emailed suggested fixes (all of which were posted on various forums from similar experiences.)  Just for kicks I tried them as well, with no success.

Sansa is RMA’ing my player.  They furnished the UPS label and I sent it last week.  Apparently the players are warrantied for 1 year. 

They issued the RMA virtually no hassle; that was nice. 

We’ll see how long the new player lasts; hopefully I have no issues cause I really like the player. 

I’ll repost when I get my new one.

I just sent them another email, once again no reply.  How long did it take for them to get back to you?

Just call 1-866-SANDISK and they will start a RMA process. There is no software recourse if it gets stuck on the Sansa screen.

It seems to be an epidemic since my device worked fine for 10 months until this week. They must have mis-calibrated the “planned obsolescence” program to trigger at 10 months instead of 14 months after the warranty expired… :slight_smile:

For whatever it’s worth, my Sansa m250 seems to have the same problem: it will power up but hangs at the Sansa splash screen. It has v4.0.44A firmware and is probably about 10 months old. I hope SanDisk will replace it.

I have had the same problem, except with the m240.   I did an RMA exchange in September; a week or so ago, my replacement m240 did the exact same thing, freezing up at the splash screen.   My new player had a different firmware, 4.0.45a I believe, but that doesn’t seem to make a difference.    Very frustrating - I will probably try to get another RMA going (I sent an email to support@sandisk.com a few days ago) but I have zero confidence that a replacement will be any more reliable than the two I’ve had.   

Update:

I sent Sandisk 2 e-mails about the problem.  I never received a single response.

Then I called the Tech Support and spoke the representative who tried to fix the problem with basic fixes, such as remove the battery and put it back in.  Finally, they are going to send me a new one.

I asked him about the numerous posts people have posted about this exact problem and if I should download a new driver or firmware once I received the new one, and he “assured” me it was an isolated problem.  Yeah right.  Well, we’ll see how long this one lasts.

I received my RMA unit about a week ago; so far things are working fine. 

All in all it took me about 3 weeks (from response to second email,) to get the unit. 

Fingers-crossed, we’ll see how this one goes; I saw a lot of reviews on Amazon who said they experienced the same problem even with the RMA’ed unit.  Hope that’s not the case…really like this player, just have no confidence in it at the moment.

I made sure I registered this one with Sansa tho…

Try this:

Right click in the explorer window on sansa device and format.

This should reset and erase everything.

For mine at least, the “frozen” Sansa no longer presents itself to a computer as a disk drive, so reformatting is not an option.

Hey SJPRATT,

Your comment …"…It seems to be an epidemic since my device worked fine for 10 months until this week. They must have mis-calibrated the “planned obsolescence” program to trigger at 10 months instead of 14 months after the warranty expired… :-)"…

…is hilarious !!!  

You’ve got that right…“mis-calibrated the (internal) planned obsolescence program” that Enigma seems to think is a perfectly acceptable way to do business !

Wouldn’t it be nice if these “senior” members actually READ what people report as their symptoms, like “device totally locked up, even after taking out the battery”…before they say "oh, just reformat it in Windows!

I telephoned SanDisk the day of my original post and they gave me a case number, RMA number and told me to wait for a return envelope to arrive through the mail.  I’m still waiting.

My pc doesn’t even register the sansa when I plug it in. I don’t see it in the explorer window.

How did you do it? Plug the sansa in then turn it on? I had it on (in the frozen state) and then plugged it in.

Windows doesn’t see it.

I have the same problem with one of my daughters sansa mp3 players (m240 firmware V4.0.44A). I purchased it in Dec 06 and it began freezing In Jan 08 1 month after the warranty was up.

I have tried all options on resetting this unit and it appears to be unrepairable. Really such a shame, I am very happy with the other sandisk mp3 players i have purchased for my other children (differnt model #'s as well as different firmware versions)

This unit was used very little and taken very good care of. It certainly didnt begin to freeze up on the startup screen because of use but because of the defective firmware vesion.

I guess my point is there are probably alot of people who just went out and purchased a new one, or didnt take the time to mess with support or get their unit rma’d- because they were not aware that the problem was from a defective firmware version , but an actual defective unit. Even if it freezes after warranty,most of these units would all still be ok if they had a functional firmware to begin with. I’ve always taught my kids to take care of their things and they will last much longer. that just is not the case with a defective product.  I think any 200 series players with this specific bios version and this specific problem should be recalled, replaced regardless of date of purchase. Some people can afford to buy a new one every year,  I however cannot. I wouldn’t normally expect something to be replaced after warranty - only if it was a defective product. Only if my daughter would have used it more often it would have probably began freezing within warranty.

I sent them an email today. If they take care of me I’ll gladly continue to purchase their products in the future. 

Add me to the list.  My M240 froze tonight.  It was purchased as a Christmas gift in 2006.  My son brought it to my attention and I’ve been messing with it about an hour now.  I’ll call and see what they say, but I have little to no hope