e260 Keeps Restarting


I’ve had my e260 for a couple of years, and all of sudden every time I try to do anything with it, it shuts down and restarts.  I can’t even change the USB mode to reinstall or upgrade the OS.  It won’t even shut down when holding the power button, it always reboots.  Any help would ge GREATLY appreciated.  Thanks!

What if you press & hold the power button down? This normally induces a soft reset. Hold it for at least 20 seconds. or try taking the battery out for a while and then putting it back it. Maybe that will un-stick it’s ‘deja-vu’ loop.

I’ve tried both of those.  Holding the power button down, no matter how long I hold it, just causes it to restart again.  Removing the battery (I left it out overnight) didn’t make any difference either.

Let’s stay with the mechanical side of things for the moment.  With the back removed, press downward on the memory module to see if we might have an I/O problem with the socketed unit.

Above the battery, you’ll see the black area; within this you’ll see the grey foam block.  This presses the memory module into position on its socket.  I’ve seen devices where the daughterboard pops free from the main board.  It will seat with a soft click.

Bob  :wink:

Thanks Bob for your efforts.  Unfortunately, that didn’t work either.  Is there any type of combination of keys I can depress that causes a reset of some sort?  I don’t think it’s mechanical, but maybe the battery needs replacing?

Maybe it would help to better describe the problem.  Whenever I get to the point where the device has to do something, as opposed to choosing between menu options, instead of playing the song or switching its USB mobe, the screen goes gray (with some lines through it) and fades to black, and then it restarts.  Hope that helps.

Sounds like you have a v1 device, a bit more prone to this type of ailment (cycling).

I would recommend using recovery mode to reinstall the firmware on the device.  It sounds like you may have a corruption in your Sansa’s vital operating firmware.

To initiate recovery mode, start with the Sansa OFF, then slide the top HOLD switch to the right (orange showing).  Simply connect the device to the USB port while holding the REC button depressed.  But don’t do this right away.  First, you’ll need to download a new copy of the firmware in this thread.  There are two files you’ll need plus one optional one, a folder renamed sansa.fmt that you can place into the group, that will tell the Sansa to format the data area of the device, allowing you to start anew (in case you have corrupted music files, or want to start with a clean slate).

Let’s try this repair in steps: we’ll use something completely different, a SanDisk utility for restoration of the v1 device.  Download and run this little applicationafter connecting your Sansa in Recovery Mode first.

7 Feb 2010: Sorry, folks, the SanDisk 12a recovery executable is currently unavailable.  The automated recovery tool was very handy (but it has a flaw, in that the installed firmware has no equalizer function).  It was necessary to update the firmware to the latest version afterwards, but I liked it for sake of simplicity.  -Bob

You’ll see a SanDisk splash screen, then the utility will automatically find the plugged-in Sansa, and will install a basic firmware onto the device.

The “12a” firmware is very basic, in fact, it doesn’t have the custom EQ, but it will run your v1 well.  Slide the Hold switch back to the left, and unplug.  The firmware will load into your Sansa.  Then try and see if it now operates normally.

Your next step is to install the current firmware (or you can install the previous one, my favorite, 18a).  Follow the manual installation instructions in the v1 firmware thread.

Let us know if you have a happy Sansa after these steps.  If it continues misbehaving, while the Sansa is connected in Recovery Mode, while in the 16MB FORMAT partition, right click and DO NOT SELECT FORMAT, select, “New Folder”, then RENAME this folder sansa.fmt and place it in the displayed 16MB directory.  This folder will be interpreted by the sansa as a command to automatically format the data area of memory.  Sometimes, corruptions in this area will cause the v1 to freak out.

You will then have to reload your music, as formatting erases all media from the device.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 02-07-2010 11:23 AM

Well, it looks like I’m back to enjoying music again!  Thanks so much for all of your help.  The firmware upgrade worked and all seem’s well.  You guys are great!