e260 How to Reformat from NTFS to FAT / How to fix no drive space

I got my e260 stuck in NTFS and could not get it to reformat to FAT. After looking for 2 hours i found how to fix it.

 Power off player.

Move HOLD button to locked position (towards headphone jack).

Press and hold the RECORD button.

Connect to computer.

You can let go of the RECORD button once you see a message to the effect MSD Connected.

Open My Computer.

Open 16MB-FORMAT drive.


Create a new folder on the 16MB-FORMAT drive called sansa.fmt

Use Safely Remove Hardware icon (or Right Click on 16MB-FORMAT and choose Eject)

Unplug player from computer.

The player should now format itself and boot back up into the Language selection screen.



This was posted by TheMarkster so send thanks to him. Im just reposting under a name that will be easer to find in a search.

Note this only works on v1 models that have a RECOVERY mode. V2 hardware configurations do not.

ks. But for V2 devices, what is the easiest/safest way to convert this? 

@markwahl wrote:

ks. But for V2 devices, what is the easiest/safest way to convert this? 

Convert what?

You ask the same type of inane questions as another member, mikkirourke. Are you the same person posting under 2 different names?

On the v2 devices, the Sansa has a different processor and no “16 MB FORMAT” partition. To restore the file structure to FAT32, the v2 can self-format via going to Settings > Format > Yes. this will reformat the device to FAT32, but it does clear all existing music files from the device.

If the device will not espond, allowing you to navigate to Settings on the main menu, you can first try resetting the device by holding the Power button depressed for about 20 seconds, release the button, and try powering up again.

Alternately, if you plug in to a Windows PC, you can connect, navigate to the device, right click on it, and select Format. Use the basic Format function and not “quick format”, this is what I’ve always found to work best.

Note, this is for the later v2 devices. You can format the v1 this way, as long as you are not connected in recovery mode. Formatting the recovery partition removes critical data. For the v1, earlier player, use the Sansa.fmt file trick in the top post here.


To verify if you have a  v2  device, this is quite simple. When powered up, you will see a SanDisk logo with reflection, and a blue  sansa logo pops up moments later.



Well …at reviewing posts and user accounts, I found this …

1- doncht          -> (14-02-2013  to 30-03-2013)

2- dwaynnyt      -> (31-03-2013  to  26-05-2013)

3- rickyjm          -> (09-05-2013  to  25-10-2013)

4- jimmyghd     -> (29-10-2013  to  28-12-2013)

5- mikkirourke  -> (03-01-2014  to  02-03-2014)

6- markwahl     -> (07-03-2014  to  27-04-2014)

7- kitscht            -> (28-04-2014  to   –  Now   – )


So, I tried this. It went as far as saying it was formatting, it restarted and prompted me with the “Load Main Image Fail, Switch to Recovery Mode” I have tried the firmware updater and it doesn’t even recognize that the player is plugged in. I have not tried the firmware update patch, because I can’t access anything of the player. The only folder that shows up on my computer when I plug it in is the 16mb Format. I’m stumped.