Driver Issues with Windows Vista

Hello all, 

I just purchased a Sansa Express, and upon plugging it into my system (currently running Windows 32-Bit Ultimate Edition) it is unable to find a driver.  I held the “-” button upon inserting the device, and I was able to upgrade the firmware.  However every time I tried to install the actual driver, it simply wouldn’t take.  Currently in the Device Manager, there is a “!” with MTP device being listed.  Windows has been updated with the latest patches/hotifxes via Windows Update.  Any ideas on how to resolve this? 

Thank you for your assistance, 


Also, I plugged the device to perform the initial charge of the battery, but I removed it four or five times while trying to get the driver to work.  Have I negatively impacted the battery by doing this?

There is no impact on the battery by unplugging and plugging it back in.

Heat is what kills a battery and overcharging causes excessive heat.  I’d recommend limiting the charging time to no more than 2 hours at a time.

Thank you for the info.

Does anyone know anything about the driver problem?

@thewave2002 wrote:

Thank you for the info.


Does anyone know anything about the driver problem?


The Express is an MTP device. You need MTP drivers to connect the Express in its default MTP mode. The MTP drivers are part of MS Windows Media Player. You will need Version 10 or 11.


If you do not have WMP installed, download and install it from the MS website.


Try different USB ports on your computer. On some computers, the back USB ports seem to work a bit better with MP3 players.


With your player connected, try to update the drivers through Device Manager.  


If those suggestions don’t work, try a couple of hotfixes from MS. The first is a porting kit to replace or update the MTP drivers. The second is a repair for a corrupt infache file which occasionally causes a problem similar to the one you are describing.


Message Edited by Mr_Moose on 05-15-2008 08:30 PM

-  I have WMP 11 installed on the system.

-  I have used both the front and back USB ports on the system.

-  I have tried the second link you have provided.  I will try the first one upon arriving home after work.

Thanks for the suggestions!

Try deleting or removing the existing driver (the one with the yellow !), from the Device Manager window.  Then reboot the PC.  Windows will “find” new hardware and reinstall the driver during the reboot. Hopefully you’ll get a good install this time.  That’s what I did to fix mine.

I’m using Vista Ultimate with the Sansa Express and now have no problems.