Express won't work correctly neither in MTP nor MSC mode

I have a pretty uncommon issue:

 When connected to a PC, my sansa express shows up in device manager as Sansa express (with an exclamation mark) for a few seconds and then dissapears at all (the player switches on as usual not like when connected to a PC but is charging if needed).

tried updating the driver, it says driver instalation succesful, but the device still turns on like before and dissapears from the system in a few secs.

 As you can guess it doesn’t show up neither in My Computer nor Media player.

When connected in MSC mode, the player shows up in device manager as STMP3600 (with an exclamation mark) and when trying to update the driver, it says that it cannot instal it.

any help would be highly appreciated.

You may have a hardware failure.

Try this.

The problem is that I can’t get it to work even in MTP mode, so there’s no way of “changing” it to MSC.

If it helps I’m running Windows 7 build 6801 (which couldn’t be the problem as this issue occuried back when I had XP sp2) and the player has an 8Gb Sandisk mircoSDHC (which seems to work as good as when I first installed it)(I’ve tried connecting the player to the PC with the SD removed - no changes)

tried soft and hard reset, formatting, updating firmware (back when the player worked fine)(btw, I have the latest firmware)