Sansa Express not working! Please help me!

My Sansa Express stopped working on the first day. All that appears is the Sandisk Logo and then Shuts off, I tried a lot of stuff to get it working. I read a lot of boards to start my Sansa Express none of em’ worked. Please help me, or walk me through the steps correctly. Thank you!

I got my Sansa Express on June 5, 2008. It stopped working on the first day, tried to fix it. Didn’t work. Went to boards, no help at all.

There isn’t an MSC mode you can set on the player, but you can do it on a per-computer basis through Device Manager by telling it to use MSC drivers:

Open the Device Manager on your Windows PC of choice
Find the Express under Other Devices or Portable Devices
Right-click on the Express and click Properties
Click “Update Driver”
If the wizard asks you to connect to Windows Update, say “No, not this time”
“Install the software automatically (Advanced)”
“Don’t search, I will choose the driver to install”
Then, select USB Mass Storage Device and click Next, and you can finish installing MSC mode drivers.

The change will be persistent on the computer where you do this, but other computers will still see the player in MTP mode unless you do it there as well.  The Express really wasn’t meant to be used in MSC mode, so if you break something, you get to keep both pieces


Tried the method, didn’t work. 

Have you tried to talk to tech support? They can be very helpful at times.

I tried performing above steps, but still it is not working