Switching from MSC back to MTP mode

I recently changed my Sansa Express to work using MSC mode using the following instructions:

  1. Plug in your device. It should be recognized by the system and installed as an MTP device the first time you plug it in. (If it isn’t recognized, see post in this thread: http://www.anythingbutipod.com/forum…ad.php?t=12603.)
  2. Open Device Manager. Find your Sansa Express under Portable Devices. Right click. Update driver.
  3. Select: No, not this time, Next.
  4. Select: Install from a list or specific location (Advanced), Next.
  5. Select: Don’t Search. I will choose the driver to install, Next.
  6. Be sure to check the box beside Show compatible hardware.
  7. Highlight USB Mass Storage Device, Next.
    You’re supposed to be able to swtich back to MTP mode (I wouldn’t want to normally, but Audible manager only recognizes the Sansa Express in MTP mode) using the same instructions, except instead of Clicking USB Mass Storage Device you switch back to “MTP Device”, but mine doesn’t give me the option, it only says “USB Mass Storage Device.” I’ve tried uninstalling the MSC drivers and then rebooting, hoping it’d default back to MTP, but it won’t. I’m using WinXP SP2, so it should, right? Does anyone know if I can just download the driver so I can install it manually?

Edit: I notice its using USBSTOR.sys and not wpdusb.sys (like my laptop is using and it can switch back and forth fine) anyone know how to manually switch them out?

Message Edited by discordjack on 08-26-2007 11:32 PM

It helped me so much !!! 10x !!!

Try updating your your USB driver.
It might work/
Or Update your Firmware.

Message Edited by zak4994 on 08-30-2007 06:43 PM

I am running vista, and I switched to MSC mode, and now I can’t switch back to MTP mode.  I have tried formating the player, uninstalling the device, updating, etc.  When I choose MTP, I get an error saying it can’t load the drivers for this device (code31).  Any thougths on how to force it to MTP mode, or remove the device entirely from vista’s knowledge, so it goes back to the default of MTP?

Can it works also in Win2K (with MTP Porting Kit)? Because when I bought my Sansa 1Gb in Alberta, I plugged it the first time in a WinXP and it detected my MP3 like an MTP device. When I went back to Quebec, our home computers have Win2K. No XP here. So I plugged my SE in my Win2K and it was detected like an MSC. I liked MTP and I want to put it back but I can’t because MTP isn’t detected by 2000. So I installed MTP porting kit for that reason. Since that day, my SE is an MSC everywhere, even in XP. So I repeat my question: can it works also in 2000?

MilesPrower wrote: 
… can it works also in 2000?


I do not believe that you can connect in MTP mode in Win 2000.


You need the MTP drivers that are in Windows Media Player version 10 or 11. Those versions require Windows XP.

Thanks a bunch for helping get my new player working ! cheers

I had the same problem of not being able to switch my sansa express from MSC back to MTP mode after I updated the firmware.  After 3 days of doing every thing with no luck, I was told by my daughter that the problem was not with my Sansa but with the change of registry in my computer when I switched MTP to MSC in my sansa – I used the steps outlined by one of the forum member for updating the firmware in.  She asked me to connect the sansa to a different computer (a desk top) to see if that was the case.  Believe it or not,  my sansa showed up in MTP mode in the second computer!!.   Thus, to get my Thinkpad to “see” the Sansa Express on MTP mode, I did “system recovery”, selecting a date prior to the date of switching the sansa mode and updating its firmware. After days of frustration, I am glad to have my sansa with an updated firmware and on MTP mode. 

So, for those who switched their sansa to MSC mode (using their computer) to just update the firmware and can not switch it back to MTP mode, try what I did.  Hope it works… Good luck!


Please note that in my 8/14/08 post, I mentioned  the use of “system recovery” but I should have said “system RESTORE”.  So, if you used your computer to change the MTP mode in your Sansa Express to MSC mode, you have just changed the drivers assigned to your sansa in the computer to recognize it as an USB mass storage device.  In this case, you can use your computer “SYSTEM RESTORE” function to restore it back to a day before you made the change in your sansa. I am assuming that you have set up your comuter to perform automatic “back up” regularly, and by restoring your compure back to a few days earlier you do not have important data to loose.  If so, you need to back up the data. Good luck.


To change mode back to MTP, just RIGHT click on the icon in System Tray (Safely remove hardware), and choose the only option. A window appears, there you click on Properties > Driver > Update Driver > Not now > Advanced > Don’ search. After that, you should see two possible drivers - MSC and MTP. Choose MTP. After installing it, my computer ended up saying that “Device could not be turned on”, then I disconnected Sansa, reconnected it again and it worked as MTP.

Here is the way to switch back from USB mode to MTP mode in Win XP (SP2)

  1. Plug your sansa express

  2. In the desktop taskbar double click open the  Safe Remove Hardware window.

3.  From the Hardware devices select the ‘Sansa Express’

  1. Click Proerties and select the ‘Driver’ tab

  2. Click ‘Update Driver’ 

  3. Select ‘No, not this time’  and then select ‘Install from a list or specific location’

7.  Select ‘Don’t search, I’ll choose the driver to install’.

  1. Make sure the check of ‘Show Compatible hardware’ is selected

  2. Select ‘MTP Device’ and click Next

  3. Thats it you are done. No need to do system restore and criticise Operting systems. Look for the ways to do it. 

Next time I need to do an update, I will try your 10 easy steps. I spent quite a bit of time trying methods of doing what you accomplished so your scolding does not reflect well on you. Currently my Sansa Express (firmware rev 01.01.12A) drops all my songs every time I re-charge it. A royal PITA - “waste of time” to reload all my music every time, but hey, it’s a niffty little package that only cost me $20 so I can live with it until it (or me) dies!

Thanks jerry157!!! After i debricked my sansa express (using the thread by that title), I couldn’t’ get Windows Media Player (or Overdrive or Audible) to recognize it as a portable device. After following your directions to get it back to MTP mode, it’s 100% fixed again!!