Drive will no longer mount on mac

Same problem iMac 2017 date mid June 2021; RESOLVED issue this time doing a Disk Utility First Aid run then restarted - magic T5 suddenly mounted after multiple other attempts.

Sandisk Extreme SSD would not mount on 2016 macbook pro or on new 2021 macbook M1. Disk utility would not mount. FYI, You cannot run Disk Utility First Aid without mounting the drive, so don’t understand why some users report this as a solution to the drive not mounting. Resetting PRAM had no effect. RESOLVED: Disk Drill for Mac mounted the drive without issue. Once the drive was mounted in Disk Drill it appeared as mounted in Disk Utility. At this point it was possible to run First Aid on the disk. Exit code on the disk was 0, disk repair corrected the error and now all is good, for now :slight_smile: Hope this helps.

Had the same problem. Extreme SSD 2TB (model SDSSDE60-2T00) would not mount, even in Disk Utility; tried on two Macs with the same behavior. Running Disk Drill mounted it without any action required; the drive then mounted in the file system, again, without any action required.

Same problem here!
It was just working perfectly fine but after disconnecting and reconnecting problem occurred says, “the disk you attached is not readable by this computer”. Very frustrating as I was preparing for my next project! Everything on the “Disk Utility” page is greyed out not clickable. Cannot afford to lose everything on this SSD.

Found Solution after countless hours of research and phone calls.
My SSD was not mounting to my MacBook and the disk utility tab was all grayed out (not clickable). I couldn’t use first aid nor mount or erase options so the only suggested option from SanDisk was to replace it as my drive is still under warranty. However, I installed the “San Disk Security” App and it miraculously connected as soon as I punched in my password! I finally have access to all my folders!
Hope it helps someone!

My drive that I’ve used once probably before the update to Big Sur was functioning fine. Below is an image of my SSD, attached, with Sandisk Security app, showing that there is no volume.

SSD not showing on my Mac
SSD not showing on Disk Utility

Please help, anybody.

Just register an account to reply. I have sandisk extreme SSD 1TB. One day, it couldn’t show up, not mount, tried different cable and connect to other laptop, PC, doesn’t work. Then I tried to run mac Disk Utility, it shows as unmounted, then I clicked the “first aid” button, it actually run and report with no problem. After “first aid” finished, it is magically shown as mounted.

I had the same issue with my 1TB Sandisk SSD. The default cable it came with is USB C to USB C. Mu Mac is USB C as well so I’ve just been plugging it into one of the ports and its worked fine for over 2 years. Suddenly it stopped mounting. I found that using a USB A to USB C cable, with a USB A to C adapter on my mac it mounts in seconds!

I also encountered this problem on an outdated mac. After several checks I found that on a newer mac everything worked regularly (even the sandisk security). I noticed that on the older mac the USB 2.0 had a voltage of 5.0 volts instead of 5.1 volts of the PCs on which everything worked

I used the cheap adapter and faced the same issue with you all. But the SSD works well after I used the USB-C Digital AV Multiport Adapter bought from Apple store. Hope the mounting issue not happen again.

Hello, everyone. I have the same problem with my 2TB SSD. I read all the comments and I think I have all of them at once.

So, everything began after 2 months of buying. Before that, everything worked perfectly: It mounted in seconds and I was able to reject it in milliseconds.

At first, I had a message that SSD was not ejected correctly and it may had a problem. But I have never ejected without Eject, or during writing process. I thought I accidentally reject it because cable was so short. No problem. Nothing. Then, when I was in a hurry and needed photos ASAP (I had a Lightroom catalog in it) it did not read. Unplug and plug it again. No response. And problems began there. After several days from that, it did read, but my breath would disconnect it. After that, it did not read at all, even though I tried with different Macs (no PC, btw).

Two days ago, I don’t know why, but I decided to plug it and try my luck. And WOOOOOOW. It did worked. My joy only lasted for 1-2 days after everything started happening again. I researched hours and hours and I think I found a solution on Apple’s Developers forum. Here is the link: com.apple.DiskManagement.disenter … | Apple Developer Forums

I cannot try this because I do not have admin permission to do “sudos” on my work computer. I will try this on my personal Mac when I have access to it but before that you can try doing it and share me the results.

I hope it helps. So many disappointed users and ZERO response from the manufacturer!!! NOT COOL.

have you tried with another cable, new maybe? to clean the socket in the MAC with compressed air?

Now I finally found a solution (only on ExFAT format):

  1. Connect your SSD to your computer;
  2. Run Disk Utility
  3. You will see greyed Extreme SSD there and with two-finger click, choose Mount.
  4. Now you must open Terminal.
  5. Type exactly this: sudo pkill -f fsck
  6. Type your login password

After that, you will be entered in a read only mode. Try to back up all your files, then format it and try another brand’s SSD. At least, your files will be safe.

Yep, after running the above workaround, I’m returning my SanDisk. I can recommend Samsung’s T7 - it has fingerprint pass too works great with my Mac. Shame SanDisk can’t even be bothered to reply and address this issue.

@bmamukashvili solution worked for me as well.