SanDisk Extreme Portable 500G - Cannot see the external drive on Disk utility on MacOS

My drive was working perfectly till 2 days ago. Nothing happened anymore when I connect it to my MacBook Pro. I cannot see the drive also in the disk utility app.

I tried to reset the NVRAM and the SMC on my Mac but nothing change.
I tried to connect it on a windows computer, same problem.

I noticed that even nothing happened, the drive is a bit warm so it makes me think there is a kind of connection inside.

There are 3 partitions on the drive, one for TimeMachine, an APFS partition for my storage on MacOS, and a small NTFS partition to transfer files with some other computer if needed.

The drive is under warranty, but if I send it to Sandisk, they will just replace it and I will loose my datas right ?

The drive never fail, and I paid a lot of attention to it.

Could it be the controller between the SSD NVME disk and the USB-C port that is not working anymore ?
If so, should I try to open it and connect it to an other usb controller ?

Or is there an other option to try ?


I don’t have any answer yet but I found this in case it can help someone else…

I will have the tools to open tomorrow I will let you know what I might find