Drive will no longer mount on mac

Our SanDisk SSD stopped working all of a sudden on our Mac as well. We couldn’t see the drive in Finder and it didn’t work anywhere. We checked Disk Utility on the Mac and it showed a faded SSD name and reported as “Not Mounted”. However, when we connected the same drive to a Windows PC, all the files were intact. I think we could have scanned the drive and been able to Restore it to its default way but we opted to copy the files out, format it and get it to work again.

I have exactly the same problem. Did you happen to resolve it in the end

Just wanted to say THANK YOU, it worked! My 1 TB Sandisk SSD stopped working (maybe that’s the cable? no idea so far). Installing the Disk Drill helped! Thanks!!!

@ bmamukashvili it also worked for me. Thanks. :slightly_smiling_face:

Worked for me as well. I had to remove the password on the drive as well, then it formatted and all was good.

I could safe all my files with Disk Drill, but could´t mount the ssd. Not via Disk Drill, not via Terminal, not via Disk Utility…nothing worked.

The only solution that worked was:
I connected the ssd to my phone, formatted it.
First it did not format, tried a second time it succeeded.

Then plugged back to my mac m1 and erased again to APFS and all is good now.
Let´s see how long!

Everyone! Go to Activity Monitor, under Disk tab search for “fsck_****” where **** is whatever your drive type is. Anyways force quit it and you’ll be gucci💋

The firmware update tool is now available.

https://forums.sandisk.com/t/sandisk-extreme-portable-ssd-v2-sandisk-extreme-pro-portable-ssd-v2-and-wd-my-passport-ssd-external-drive-firmware-update

1 Like

Connect the Extreme portable SSD to a different USB port on your MacBook Pro. This can help determine if the issue is specific to a particular port.

1.As someone who has experienced a similar issue, I understand how frustrating it can be to face data loss due to a broken SanDisk Extreme SSD. However, there are solutions available to help recover your lost data.

2.To learn more about official solutions to this issue, I recommend visiting the SanDisk website or reaching out to their customer support team for assistance. They may be able to provide you with specific steps to recover your data or recommend a professional data recovery service.

3.Additionally, you can visit the following guide page to learn more about how to recover your data on broken SanDisk Extreme SSDs: SanDisk Extreme SSD Failure: Tips to Prevent from Further Damage This page provides detailed instructions and tips that can help you recover your lost data. I hope this information helps you to resolve the issue and recover your important files.

I purchased a San Disk Extreme Pro Portable SSD Model Number SDSSDE61-1T00, from Costco, November 2022. I have used it multiple times every week since then now it will not mount. I have tried different cables and 3 different MACs. Is there a solution to this problem? Or should I send it to SanDisk for a replacement?

Thanks for the advice but I have tried to connect it to 3 different computers and it will not mount on any of them.

WTF, we are 2024, and yet after buying a new one this week I have the same problem?

I spent some time searching and came up with this solution that did work:

First, check if you have a NTFS hard drive. You can do this by going to Disk Utility (by pressing Cmd + Space)

If you have a NTFS file system, you can try the Paragon NTFS Driver. However, I haven’t had much luck with the NTFS file system on Mac. So I’ve ended up formatting them to ExFAT.

If you have an ExFAT hard drive that isn’t mounting, try running the following commands -

  1. Plug in your hard drive
  2. Run ps aux | grep fsck - This will show if fsck is using your hard drive (typically happens when you don’t eject it properly)
  3. Run sudo pkill -f fsck - This will kill the process and immediately show your hard drive in Finder

Hope this works!

1 Like

Yeah this discussion is very useful. Try the above mentioned steps:

1. Relaunch the Finder.

The discs may be mounted and available; however, if the Finder is having troubles displaying them then it may appear as though the discs are not mounted. Press the Option key and right-click the Finder icon in the Dock, and choose “Relaunch”.

2. Change the port.

Sometimes there are differences in the USB ports on the system, which result in power or speed differences that can result in external devices not being recognized properly. Try each USB or FireWire port available on your system (use FireWire 400/800 adaptors or conversion cables if necessary) to see if that helps. You can also try this when booted into Safe Mode, to see if any third-party plug-ins or nonessential features of OS X are contributing to the problem.

3. Plug in power adaptor (if available).

Some external drives come with optional power adaptors (especially smaller and more portable drives). If you have one, try plugging it in so the drive is not reliant upon bus power. Low power can definitely prevent a drive from working properly.

4. Avoid daisy-chaining.

When troubleshooting USB or firewire devices, unplug all except for the problematic device (and your keyboard and mouse, of course) and plug it directly into your system. Do not route it through the keyboard or a USB/FireWire hub, as this is yet another source for incompatibilities and problems.

5. Try a different connection type.

Some devices have both USB and FireWire ports, so use each of them to see if the device works. If it does with any of the ports, then you know the device is probably not to blame and can focus on troubleshooting the bus/connector that is causing issues.

6. Run general maintenance.

Give your computer a once-over maintenance run. Reset the PRAM and SMC, followed by booting into Safe Mode and clearing caches and performing a permissions fix with various maintenance utilities (********, Yasu, OnyX, just to name a few). Then boot normally and reboot again (the first boot will fill caches and be a little slower than the second) before trying the problematic external drive.

7. Drive problems

Last but not least, there may be problems with the drive itself, which can be caused by a number of issues including power or connection interruptions without properly unmounting the drive (a frequent occurrence for external drives).

Hope this will be helpful.

I tried with some solution that did work for me:

  1. Check the connections: Ensure that the USB cable or other connections between the external drive and your Mac are secure and properly connected.
  2. Try a different port: Try connecting the drive to a different USB port on your Mac. Sometimes, a port may be faulty, and switching to a different one can help.
  3. Use Disk Utility: Open Disk Utility, which is located in the Utilities folder within the Applications folder, and see if the drive is listed. If it is, select it and click the “Mount” button. If the drive is not listed, try clicking the “First Aid” button to run a repair on the disk.
  4. Update the driver: Check to see if there are any driver updates available for your drive. Visit the manufacturer’s website and download the latest driver for your drive.
  5. Check for firmware updates: Some external drives may require a firmware update to work properly with newer versions of macOS. Check the WD support website for any available firmware updates.
  6. Try on another Mac or PC: If you have another Mac or PC available, try connecting the drive to it to see if it will mount. This can help determine if the issue is with the drive itself or with your Mac.

If none of these steps resolve the issue, there may be a hardware problem with the drive itself. In this case, you may need to contact the Sandisk technical support team for more information.

I faced a similar issue with my drive, appearing in Disk Utility with a name but being unmounted, rendering it inaccessible. With my MacBook’s Windows 10 Boot Camp, I connected the drive, prompting Windows to detect and recommend scanning and repairs due to an issue. Allowing the process to run, it took roughly 12 minutes for my 2TB drive, containing a relatively small file. After completion, I reconnected the drive to my Mac, where it functioned normally again. This method resolved the mounting and accessibility problems effectively, showcasing the benefits of a cross-platform approach in troubleshooting such issues.

Try following these steps; they worked for me and might help you too.

There could be several reasons why the drive is not being recognized or mounted properly. Here are a few steps you can try to troubleshoot the problem:

  1. Check physical connections: Ensure that the SSD is properly connected to your computer. Try disconnecting and reconnecting the drive, making sure it is securely plugged in.
  2. Test on a different computer: Connect the SSD to another computer to see if it can be recognized and mounted. This will help determine if the issue is specific to your computer or the SSD itself.
  3. Use a different cable or port: Try using a different USB or Thunderbolt cable, as well as a different port on your computer. Sometimes, faulty cables or ports can cause connection issues.
  4. Update drivers and firmware: Check if there are any firmware updates available for your SanDisk SSD and install them. Additionally, make sure your computer’s operating system and drivers are up to date, as outdated software can sometimes cause compatibility issues.
  5. Run disk utility tools: On macOS, you can use the built-in Disk Utility tool to diagnose and repair disk-related issues. Open Disk Utility, select the problematic SSD, and click on the “First Aid” button to run the repair process.

If none of these steps resolve the issue, it’s possible that there might be a hardware problem with the SSD itself. In such cases, I recommend reaching out to SanDisk’s customer support or returning the drive if it’s still under warranty for a replacement or repair.

@gkramer71 I’m sorry to hear about the issue with your external hard drive. Usually, when we connect the external drive to the Mac, it shows up quickly on the desktop. But when “external drive is not showing on the desktop” or “Not Mounting External Drives on Mac“, MacBook Port, then it is frustrating cause you can’t copy or post anything on your Mac internal drive.

Here are some common reasons on external hard drive not mounting on Mac:

  • Faulty connection with external storage drive

The first and foremost reason for your external hard drive not mounting on mac could be the dirty or loose connection between the cables, USB-C multi-adapter, thunderbolt 3, or any other connection ports. The connection is only possible when the cables are attached tightly and cleanly.

  • Incompatible file system format of the drive

There are situations when the file system format of the drive is not compatible with your Mac. There are formats of the hard drive which are easily compatible with the Mac, like exFAT, HFS+, etc. So, make sure the format of your external hard drive is compatible with the system.

  • The corrupt file system of the storage device

This reason is a very common one, if your external hard drive is attacked by a virus or if you abruptly eject the external hard drive. There are chances that the file system of the hard drive is damaged or corrupted. If this is the case, the external hard drive won’t mount on the Mac.

  • Incompatible driver software of the storage device

In very rare cases, the reason for the external hard drive not mounting on a Mac could be that the driver software of the storage device is incompatible with the Mac.

Here are some of the effective suggestion in your situation:

  • Re-plug your external hard drive to another port or try another USB cable:

Firstly, the simplest suggestion is to re-plug your external hard drive to another port as out of multiple ports, some might become unsteady with a passage of time. Secondly, you can even try another USB cable. The issue can be on the USB cable, so replacing it might solve your problem.

  • Try a super slow Jam:

This suggestion might sound awkward, but it works, you can try plugging in your external hard drive in exceptional slow motion. Users have reported that plugging in slowly has mounted the drive on Mac, rather than attaching it normally.

  • Check your finder preferences:

Lastly, if the above suggestion doesn’t come in handy, you can open the finder, choose “preferences” or press (control +), and check “external disks” both in the general tab and in the sidebar tab to show your external hard drive on the Mac system.

For More: :blush:

2 Likes