device itself doesn't recognize computer connection

So I’ve been seeing a lot of posts about the sansa saying it’s connected and the computer not recognizing it. My problem is a bit different.

This started happening when I decided to charge my sansa using a wall charger. It got really hot while charging and then the next time I plugged it into my laptop:

-the sansa itself acted like it was just charging (no indication that it was connected, but it does charge, and I can still play music while it’s connected, which I couldn’t do before)

-no signal that the computer recognizes it anymore (which it used to)

I’ve tried hard resetting, starting it in various modes, but everytime I try, it just doesn’t recognize that it’s connecting to the computer.  Any thoughts would be extremely helpful, because as it is now, it’s bricked.


version 2;  firmware 03.01.16A

Sorry to ask this, but…you didn’t use an iPod charger, did you? The connector (sort of) fits, but the pins are in different places and can easily fry the Sansa.

Message Edited by c1u31355 on 07-12-2009 05:50 PM

The charger I used was made by inspire for the sansa, and looks similar to this one:

It seems to fit the port.

Well, that’s good. The unit getting hot didn’t sound so good.

The cable has different pins that transmit the charge and the data. It sounds like the charge is getting through but the data isn’t.

So that could mean a cable problem or a port problem.

Possibly the charger plug bent the pins, or something else mechanical happened.

Do you know anyone else with a Sansa, so you could test their cable on yours, or your cable on theirs? 

really still sounds like the “won’ connect” problem to me. Happens every once in a while to me.

I think the mechanical issue makes sense. I’ve tried all the options in the “won’t connect” thread, and it just isn’t recognizing either computer > device or device > computer. It’s only charging. And the Device manager doesn’t even show that anything is plugged into the USB ports (I’ve tried multiple ones).

Unfortunately, I don’t have anyone nearby who owns a sansa. I can buy a new cable, but if the port is bad, I’m out of luck. I don’t suppose there is anything I can try to do to fix a bad port?

Thanks for the help. 

If you want to make the experiment, you can get a generic cord for about $5 on Amazon or eBay.  It doesn’t have to be made by SanDisk. I’ve got two different generics that work fine.

You’re probably stuck if the port is bad–though you might take it up with the charger people, since it sounds like that is what damaged the unit.

I think I’ll do that. Thanks for the help!