sansa wont connect to computer

My computer can’t find my sansa mp3 player model e280v2 when connected. It is not listed when go to devise management. do not know what else to do.

Have you tried a diffferent USB port, computer or cable? Or switching to MSC mode?

I have a simular issue. My Sansa e280 does in fact charge, but I cannot get PCs to Recog the player itself with the msg of USB Device not recognized. so currently I have my video clips and mp3s on there but I cannot access them for removal and replacement. I have in fact checked on several different units including my laptop, my Home Office and here at work.

I have a similar answer. Have you tried a different USB mode or a different cable?

I have, in fact I’m at home and attempting to install the firmware updater to see if that resolves it. But at current standing in no bueno at the moment. Still says USB Device not Recognized but still charges. 

…I plug the Sansa in it will charge but does not show up on my computer as being plugged in and browseble. no has had this one before?

This is usually due to a broken wire inside the cable or possibly a bent/broken pin inside the 30-pin port on the bottom of the player. The fact that it is charging without issue but does not make a data connection suggests this might be what’s gling on.

Did you try a different cable? One that is known to work on another player? You might also get a flashlight or bright light and a magnifying glass and peek inside the bottom port to see if there is any lint, dirt  inside that could be blocking any of the pins connecting to the cable, or a bent one. Even if you don’t see anything, you might try blowing out the port with compressed air to see if that helps.

Of course, it could still be that there’s something awry further inside the player causing the disruption in connecting but frankly, if a new cable or a bent pin that you can straighten doesn’t help, probably nothing will.

Thank you so much for sharing this information, i am already seen thi type of information …

eh no, and I am unwilling to shell out for a replacement cord without determining fop sure w/o a doubt its a cord issue. Because I have a e280 and requires a specific cord that costs $. 

Not that much really . . .

Here’s one for a penny (+$2.98 shipping)

There’s many more to coose from on Amazon, all fairly low prices.

I suddenly had the same problem!  After much ado, (sansa m240 I use for audio books) I finally found a fix.  Under “MTP Device Cannot Start code 10” error message (for use with windows XP, although I used it for Windows 7) it said:

1)Make sure you log in as administrator.

2)Disconnect player from pc

3)Open your command prompt, Click START select RUN

4)Type cmd then press enter

5)Type the following after the prompt: Net localgroup Administrators local service /add then press Enter.

NOTE: A “The command completed successfully” message should appear. Your must type in perfectly

6)Close the command prompt and reconnect the Sansa player.

Worked for me.  r

see my post below

Still no love on the USB Device Not Recognized Error on Windows 7 Ultimate when I plug in my Sansa e280 but the e250 2 gig works fine on the same cable I even switched cables and hooked the 280 up still no love for the glove I did run your scenario thru the command prompt and it did say successful and I did close it out and hooked it up and got the same god awful msg. Anyone else wanna step up to the plate ?  I’d say corrupt firmware but how am I going to reset and format when I can’t even access it thru a USB cable?

If your e280 is a v1 model, it’s possible the memory chip on the daughterboard has become detached from the motherboard. On this model the daughterboard is plugged into the motherboard whereas on the v2 it is soldered in.

This is easy enough to check given that the e200 series is designed to be disassembled  with a small phillips screwdriver. Inside there are 4 more screws holdiing the front plate and housing together. You will see a small gray (or black) piece of thin foam padding on top of the RAM chip. Press on this and see if you hear or feel a small click as it reseats.

My sansa m230 wont connect either.  when I plug it in forced mtp mode (hold) the computer recognizes it but then if I as so much as right click it will cause the computer to hang. 

I can pull up other menus in the start menu and I can use the device when I pull it out of the computer.  It starts up and I can scroll throught the menu. 

I got a message it was full and wont function so is why I tried connecting it to the computer.  I loaded music files on there yesterday.    I had this problem last time when I had to connect it to the computer but was able to access my files in MSC mode from the USB option in the menu.  Now when I connect it in MSC mode and it causes the computer to hang (Not Responding) my computer wants to install the device driver software every time.  I get a message that says it installed unsuccessfully - installation failed.  I tried unistalling and reinstalling in the device manager, scanning for hardware changes and updating the driver but I get a message that says I have the most recent version installed already. 

I tried switching to Auto Detect mode but my computer doesn’t recognize it.  I did uninstall it in the device manager as it shows up differently, switching the mp3 player off, restarting and connecting in Auto detect mode I believe and the driver installed sucessfully but continues to hang when I click on it in My Computer.  Obviously the driver and software are installed. Maybe it’s a problem with windows? I hope I don’t have to reset the device because I don’t want to lose all my files and wondering if there’s something I haven’t tried yet… I’ve had the player since 07 and has worked well.  Recently I noticed a new menu look when I connected it with features I didn’t recognize such as not having to safely remove it anymore from my computer.

And it always says ‘Finalizing Update’. 

I have Windows Vista Home OS

Any help would be appreciated…

Your m230 belongs in a museum.

For that matter, so does Windows Vista.

:stuck_out_tongue:

thanks for the snub?

not appreciated

you obviously can’t help:smiley:

Chill. It was just a joke.

@vistacruiser wrote:

My sansa m230 wont connect either.  when I plug it in forced mtp mode (hold) the computer recognizes it but then if I as so much as right click it will cause the computer to hang. 

This actually forces MSC mode. There is no way to force an MTP mode connection. Have you tried a different cable? Maybe the one you’re using is worn out, or a wire or pin inside has broken and is shorting out, causing the computer to hang up when connected.

@vistacruiser wrote:

I can pull up other menus in the start menu and _ I can use the device when I pull it out of the computer.  It starts up and I can scroll throught the menu.   _

This also sounds like there’s a problem with the cable (or connector port inside the player) if the player works fine when not connected to the computer.

VistaCruiser wrote: 

_ I got a message it was full and wont function _ so is why I tried connecting it to the computer.  I loaded music files on there yesterday.   

What exactly was this ‘message’? Was it perhaps “Not Enough Space For Music DB. Please Free 8MB” or something similar? If so, this cryptic message usually means there is some file corruption in the FAT (File Allocation Table). This might have happened as a result (or from) the files you recently put on it, although it sometimes just ‘happens’ with these older players. The fix is to format the player, but this also erases everything you have put on it, so you will have to re-load afterwards.

But as it seems, you’ve got more than one problem going on here. You’re going to have to get it to connect reliably before you can format it.

@vistacruiser wrote:

_ I tried switching to Auto Detect mode but my computer doesn’t recognize it.  I did uninstall it in the device manager as it shows up differently _, switching the mp3 player off, restarting and connecting in Auto detect mode I believe and the driver installed successfully but continues to hang when I click on it in My Computer. 

Auto Detect (referred to as Auto Defect around here) defaults to MTP mode whenever possible, but can connect in MSC mode if conditions are not right with MTP. That’s the main reason nobody here recommends using it. Pick either MTP or MSC and stick with it. With all the problems and issues that can occur with MTP mode, nobody really recommends this either unless you are using ‘protected’ (DRM-encrypted) .wma files which require it. Otherwise, MSC mode is much easier.

The “new menu look when you connected with features you didn’t recognize such as not having the ability to safely remove it from your computer” is most likely it connecting in MTP mode when you’re used to seeing it in MSC mode. Only in MSC do you get the ‘safely remove’ option in the System Tray, not in MTP. Also, when connected to your computer in Windows Explorer, the player will show up as 2 separate drives, each with their own drive letter under “Devices With Removable Storage”. If it doesn’t look like this, the player is connected in MTP.

Don’t know whether this will help or not, but at least it should give you some information to go on. :wink:

Ok,:cat:

your response is awesome

I appreciate your insight

I need to troubleshoot this and get back with my response

I connected my sansa to my computer in msc mode today.  Again, the computer recognized it and when I clicked on Open my computer hung up.   I figured the player was just too full because I got the message “please free 4MB” which is why I connected it to the computer in the first place and encountered the problem and, because when I press the shut down button on the player and turn it off, while it’s still connected to the computer, the computer starts to function. 

I ended up trying to add legacy software and was using the wizard to try and do this and find the software on ‘my disk that came with the device’ when I came across the user manual and read that you can delete files at the player by pressing the ‘select’ button when a song is playing, thereby freeing up space.  I tried this, deleting one file and viola, when I connected my sansa to my computer I could open it, select my files and transfer them to CD! lol   

I removed it from my computer again and the player works just as before, although now empty. 

I do get a message that says Finalizing Update, which I recognize as happening regularly

I remember reading somewhere that you cannot fill the player completely as it needs room for the database and playlists to function and the problem with FAT occurs.  Obviously it was too full hence the message.

My device shows up under ‘Portable Devices’ in the Device Manager in Windows Vista and is present by name as Sansa m230 and MSC is the mode I’m using. 

The problem obviously is ‘doesn’t matter’ the device is too full.