"Device has malfunctioned"

Hi fellow sansa clip users, hopefully someone out there can help me w/ a problem that has just cropped up w/ my player.

I’ve had mine since november & it’s always worked wonderfully, I’m pretty lo-tech so I basically just drag & drop songs into my music folder when I plug it into my PC. However today I plugged it into my friend’s macbook so I could get a song, I couldn’t see any of the other songs that are usually in my music folder, but I dropped the song in & after I unplugged it I could play the song along w/ the others. However when I went home & plugged it into my PC, I was adding music & after a while it froze on the rotating charger screen & disappeared off my drivers list.

I restarted it by pressing up on the side switch, but now it won’t get past the SanDisk Sansa start screen, & it still won’t load on my drivers list, however a small warning note pops up that says “One of the USB devices attached to the computer has malfunctioned”.

Has this ever happened to anyone? What should I do? I appreciate any help/advice anyone can give. I’ve tried plugging it into a different PC, the same message pops up.

Your issue may have something to do with computer recognizing the device as MTP vs. MSC. MTP is a standard that only works with Microsoft, and I think it is required to load DRM’d music syncing witn Windows Media Player. MSC is the normal “mass storage device” standard where your computer recognizes the Sansa with a letter-drive (like a USB key or external hard drive).  You can set the Sansa (go to “settings” and then “USB options” to function as either MTP or MSC. But songs that you’ve loaded using MTP setting won’t show up if you change the Sansa to MSC and plug it into your computer, and vice versa (though all the songs are on there and will all play fine).

My guess is that your Clip is set to MTP and you’ve loaded all of your songs from your Windows computer via MTP. But the Macbook doesn’t do this, so perhaps it accessed the Clip anyway via the MSC protocol.

If you want to be able to go back and forth, maybe you can set the player to MSC in the options. I’m not sure this will still work with Macs.

What I would try to get the player working again:

  • Set the Clip’s USB mode to MSC, plug into your Windows computer, and delete everything in the “music” folder
  • Change the Clip back to MTP, plug into your Windows computer, and delete all the music in the “music” folder that shows up via MTP. If the drivers wont load properly you may have to mess around with “hardware wizard” and get your computer to load or download new drivers.
  • Change the Clip back to MSC, reconnect to your computer, and re-load the music you want on it