Dead Fuze

I have a 8GB Fuze for almost 2 months, latest firmware. Last week I let it charge over night and then went on a 4 day trip. During the trip I didn’t have time to listen to it so it stayed in a bag. When I got home I noticed it doesn’t turn on. I tried resetting it (held the power button for at least 30s) and connecting it to different USB ports (2 computers). No sign of “life”, nothing turns on ( screen or button light). Is there anything more I can do? I’m not sure if I can get a replacement, I bought it from ebay (it isn’t available in my country).

Message Edited by florin on 01-05-2009 12:54 AM

Same thing has just happened to me, charged it overnight and hadn’t been able to use it at all that day, come home and it won’t turn on or even be recognized on my computer when plugged in.

Same here…did a quick search and found that pressing the middle button and the power up button simultaneously is one of the fixes. Worked for me. Good luck

I have contacted Sandisk support and it seems it’s a hardware problem in my case. Nothing they’ve told me to try worked, so I got a RMA.

It’s quite strange, could there be a problem with prolonged charging periods? It seems the common factor in our cases.

Did you try holding the power slide up for 15-20 seconds? Try that, because it worked with my new Fuze, because I ran out on battery power, and I did that, and it was working again.

next time, I’d recommend that you leave your Fuze on hold while it is off, because it might have possibly turned on.

Message Edited by pringles on 01-15-2009 01:14 PM

after a while and trying everything to get mine to turn on, and nothing worked, i though maybe someone stepped on it, but hteres no scratches, cracks or even dents. if it is a hardware issue, then what will sandisk so about it?

I have tried holding Power for 2 minutes, nothing happened. While it’s true I didn’t use the hold switch, it’s also true that I had the Fuze in it’s velvet black “thing”, so it’s not that easy to turn on. And even if that happened, Sandisk should have thought of this and have some sort of emergency shutdown when the battery goes under a certain limit. I have an iPod Nano since 3 years ago and I did have it accidentally turn on a few times and nothing happened (other than having it’s battery drained).

Anyway, they have decided to replace mine, so overall I’m pleased.

Same here, Just got off the phone with support, and they are going to replace it, I’m guessing it was hardware failure. The guy on the phone was really helpful and I’m very happy that they decided to replace it!

I ran into this problem overnight…just dead today.  The 2 button (middle and power) solution appears to have done the trick.

Thanks for the post