Database Refreshes Everytime Device Is Turned on

Hello. I have a 4gb Clip and it goes straight to “Refresh Database” everytime I turn it on. The issue started about a week ago when someone accidentally tripped on my macbook’s power cable and my battery died while the clip was mounted. Now my mac won’t even recognize the clip. Once I get passed “Refresh Database” everything plays fine. It’s really annoying to have to wait a good minute or two for it to refresh. How can I fix this?

I think a format from the Clip’s Setting menu will help if there is a file corruption issue, which it could be since it was disconnected abruptly.

Just did that but the problem persists except now I have no files and it still takes as long.


My next suggestion is to go to the top of the Clip forum and download the firmware from the thread provided. 

Yes firmware might help, but first you need to be able to connect to it…

After the format, can you access the Clip again? If not, try going over to the Dark Side (find someone with a PC) and try to connect. If you can connect, see if there are any MacOS filesystem leftovers on the Clip (stuff like .DS_Store) and delete them manually. It’s possible that the Clip format missed something (?!) and this is tripping up the database refresh.

There are lots of past posts about Mac OS issues, try searching the forum  

So I went ahead and got on a windows machine and tried copying the m300a file over and got a “Cyclic Redundancy Error.” I ran “CHKDSK /R” and it never gets passed 0%. Is the Flash hard drive a goner?