Cruzer Facet 16 Gb not detected in Windows

Cruzer Facet 16 Gb is not defined in Windows. The computer sees the device, but when trying to open, says “no disc”. Is it possible to format the device special program?

Windows relies on it’ system drivers ro load up Sandisk flash drive including this. Can you try doing a Windows Update and see if it corrects it? 

I tried on several computers with Windows XP and Windows 7, all the same result. Previously, all worked fine. System sees the flash drive size zero, but come on I burn it impossible.

:smiley:  Hello!

Here you have two special programs (free) to try to format your UFD:

1 - USB DiskFormat (HP) Tool 2.23 in (free):
http://kb.sandisk.com/app/answers/detail/a_id/10505/kw/USB%20%20Format

2 - USB Flash Repair (LLF) 2.91 in (free):
http://filecloud.io/_cpweb34i

Also, you can check the pins of the USB Flash Drive, with a magnifying glass, for see if one is broken, dirty or bent.
Luck.

Regards, Alfred. 

These programs do not see the drive. Somehow the computer once saw her, I immediately formatted it in NTFS, and then works normally. Thank you all!

:smileyvery-happy:  Ok!