Hello everybody. I’m using this usb stick for four months without any problem. Today I lost all my data and usb stick too I think. When I plug it into usb slot, it says windows needs to format usb stick, but it sees 64 MB RAW device instead of 16 GB. Is is fixeble somehow or should I buy another one. Thanks for your answer.

I think my problem is with USB drivers. Is there any place to download 16GB Sandisk Cruzer Blade 32-bit Windows 7 driver? I know that it is installed when you first plug, but my stick fails to install driver when it is first plugged. Thanks for your answers…

Cruzer blade is a plug and play in win7, as i know there is no driver needed on your win7, have you tried using this on a different computer, maybe there is a problem with the USB.

Yes, I tried lots of Windows PC and Sun Solaris too… It was plug and play two days ago, but unable to install driver today. All platforms thinks that it is a 64 MB RAW device and needs to be formatted, but when I want to format it, the process couldn’t be completed. It is broken down somehow, and I bought new Sandisk Cruzer Edge 16 GB yesterday, hope this situtation will never occur. Thanks for your answers.

This type of problem seems to occur after the device is used in PS3s and Xboxes.  Not sure why or how.

As I also know Cruzer blade is a plug and play in win7,What I did with mine is format.

I have the same problem here. Tryed it at Win 7 and windows says that the flash drive is corrupted. Windows couldnt format and even at Mac OS X Lion the problem seems to stay.

Screen from OS X:

  1. Start your computer and plug in the flash drive in the USB port.
  2. Click on “My Computer.” Click on “Manage” in the “Explorer” window of “My Computer.”
  3. Open the “Device Manager” and locate your USBDrive installed under the “Disk Drives” tab. Right click on “Removable Disk Drive” and click on “Properties” from the menu.
  4. Click on the “Policies” tab and choose “Optimize for Performance” from the options. Click “OK” and continue.
  5. Click on “My Computer” and choose the format on the flash drive.
  6. Choose “NTFS” or “FAT32” depending on the type you want from the dropdown menu box.
  7. Click “OK” to complete the format.
  8. Know the other method: Search for tools that allow easy format of flash drives over the Internet. GParted is a formatting tool that you can download from the Internet. Install GParted on your computer. Restart your computer and browse “System: Administration: Gnome Partition Editor.”
  9. Plug in your flash drive and start GParted. Login with password information.
  10. Select the flash drive from the dropdown menu in the upper right window of the GParted interface. The list contains all the storage hardware installed on your computer.
  11. Right click on the display of the drive icon and choose the “Format to” option along with the file system type you wish to format (FAT32, FAT16 and so on).



I have a Cruzer Blade 32GB. I am trying to format it NTFS and it will not happen. I have tried everything i can find on the web including my computer, manage, device manager, disc drives, properties , policies (change to optimise for performance) etc.

Anyone know how to achieve an NTFS format on this Blade/

Anyone know how to achieve an NTFS format on this Blade/

Without knowing what error msgs you’re getting, no.

Cannot access 16Gb flash drive. When I try to format through WinXp, it cannot find the capacity “unknown capacity”, only gives me the option of selecting FAT or exFAT file systems, and an error message “Windows was unable to complete the format”. Please help. The flash drive is useless this way. Thank you in advance for any help you can give.

Did you buy the flash drive new or used?  Did it work before you tried to format it?  Do you know what format it was before you tried to format it?  If it was brand new the format would have been FAT32.

This looks like a hardware failure already. You might want to check the warranty here. I just hope that you have the option to have this RMAed.