Cruzer Blade will not format

I have just brought an 8Gb cruzer blade. When I put it in the computer it shows as Sandisk firebird 64Mb unformatted. When I try to format it gives an error reading. I have tried using partition master and it also cannot format this drive or show the correct drive size.

Using diskpart in windows also doesnt work.

How do I get this 8Gb drive formatted?

“How do I get this 8Gb drive formatted?”

You take it back to where you bought it and tell them it’s unformated and demand a new one.

I have the same problem, i have tried with many programs, but it still not working. I also have a 8GB SanDisk Cruzer Blade Flash Disk. When i plug it into my PC, it appears with 0 Bytes, has no label, only “Removable Disk”. When i try to explore it, windows show a message : “The disk in drive H is not formatted Do you want to format it now?”, and so, when i try to format it, the progress bar is in the 100%, but a message appears: “Windows was Unable to complete the format”, also, the capacity shown is 64 Mb. When i use the HP USB Format Tool, the device appears as "SanDisk FireBird 1.04(64Mb) ". How can i repair my USB?

Please i need Help!.

Thanks in advance.


You can try using the HP format tool in order to format the flash drive. You can refer to for downloading the software.

I want to be the first to thank you very much. I tried everything to make it work and thought it was gone for good. I have a 8 GB Sandisk Cruzer and was doing a backup on a windows 7 and it totally stopped working. I couldn’t see the files or format it in any way. I’m glad that I found this forum And thank you. My wife got it for me for Christmas and she was very sad to hear that it wouldn’t work. Thank you so very very much!!!

For all sandisk users

i have also experienced this problem

better you try your luck in unix or mac pc

otherwise throw your cruzer **bleep** into dumb

else go for warrenty …

as per my experience this peace of **bleep** given lot of head ache from the biggining

now i think this device is no more i have warrenty and am not ready to go for it

and further i will not buy any of sandisk **bleep** anymore…hope you people can move for transcend

nice and reliable in these days…good bye san **bleep**…!

You might want to take a look at this Announcement:

Blank Posts Please Read


u got any solution

“How do I get this 8Gb flash drive formatted?”

@pearson wrote:

“How do I get this 8Gb flash drive formatted?”

You shouldn’t have to if it’s new.

I have the same issue with a Cruzer blade 16GB that I got for christmas.

Failed to work at first plug-in. It reports a disk size of 64 MB andask for format.

However I was unable to format it on Windows and MAC.

This drive was bought some time ago and can not ask for warranty as I don’t have any vendor receipt.

???  Christmas was what 10 days ago?  And the drive was bought some time ago.  So who had the drive before giving it to you?  And what were they doing with it before giving it to you?  I suggest you talk to the giver about the problem.

The giver is my syster in law and she gave it to me as she was unable to use it. She does not know much about computers. Didn’t ask where she bought the key.

The 64MB size and description of your sister-in-law leads me to suspect she removed it from her pc without using the Windows USB Safe Removal option and the FAT got screwed up.  A fairly common situation.

The unable to format under a pc or a MAC is a tougher situation. 

What kind of error msg does the pc give when you try to format it? 

Are you running Windows 7?  Are you using a Limited access user id or an Admin one? 

Try booting the pc in Safe mode and then try formatting it.  Try erasing LIGHTLY the contacts on the Blade.  Try cleaning the USB contacts on the pc.

Windows reports “CWindows was unable to complete the format”

Well, I made further testing using winhex tool that allows to write directly to disk sector.

Result is that the 64MB sectors are all 0x00 and when writing data 0xFF it get a failure and data is still 0x00.

That explains why format does not work.

When I’ll have time I’ll try a USB analyser (got one at work) to catch the SCSI messages. I would not be surprised that the USB controller reports 64MB instead of 16GB meaning it can not access the NAND FLASH memory present in the drive.

This is a bit technical, but I’m electronic engineer and build such systems in the past creating USB drives with USB mass storage class.

What does Disk Manager show when the Blade is plugged in?  And what does Device Manager show for Disk Drives and Portable Devices.

I don’t have a Blade but I do have a couple of Cruzers, and they have two drives built into them, one of which is a CD drive for U3 software.  While U3 is gone I’m wondering if the Blade is keeping the 2 drive concept and using one for SanDisk software and one for user files.  If your pc doesn’t have a drive letter available for both drives you could be looking at the wrong part of the Blade to format.

It’s a wild theory but so to is your situation.  Let me know what you find.

The wild theory is wrong.  I bought a Blade the other day to see for myself what it had and it has only the single drive.

Kinda funny to see it has an Autorun.inf file on it.  Other than assigning an icon and label to a drive they don’t do much any more.

Thus, it seems that this boot partition is down on my drive, as it can not be formated nor written.

Is this partition 64MB size on your drive ?

No, the drive shows 4GB and the 2 folders and 3 files add up to 51MB prior to creating My Vaults.  And they all have the Read Only attribute set.  With My Vaults created I’m up to 62MB.  I did not select the option to Install SecureAccess nor create an online account.

Are you able to write a volume label to the drive?  Have you tried removing the Read Only attribute from the folders shown in the root of the drive?

 As I wrote, the disk can not be formated even can not be written using sector tools. So no way to write any label or to remove the Read Only attribute from the folders as there’s none.