8gb cruzer blade has become 64 mb skybird

I have brought an 8Gb cruzer blade 2 month ago . but now When I put it in the computer it shows as Sandisk firebird 64Mb unformatted. When I try to format it gives an error reading. I have tried using partition master and it also cannot format this drive or show the correct drive size.

Using diskpart in windows also doesnt work.

even does not work

i tried to format it in macos fail

used command promt also failed 

How do I get this 8Gb drive formatted?

please help me soon so that i can use it 

that is a bad drive most likely contact sandisk support. 866-sandisk 

I had the same problem, but i installed ubuntu (dualboot between windows 7 and ubuntu), then looked around tills i found a hardware manager(i dont remember what that thingy was called), and i clicked on a label with my usb name, then i formatted it from there… and then when i booted windows, the usb had no problem… it was like… new.

Rather than installing UBUNTU onto the hdd download the Desktop Edition and write it to a USB or CD and boot it from there.