Sandisk Cruzer Facet 0 capacity and no access under Win7

Hi all,

I’ve bought a Facet Cruzer no earlier than yesterday. I plugged it in my laptop (Win 7 Enterprise). All went fine, and I copied a directory in it at once (copy-paste, didn’t use sandisk tools).

I properly removed it (mean follow safely removal procedure).

This morning, I plugged it back: after waiting for ages, it finally shows up as “Disque amovible” (removable disk or alike I suppose, sorry my win is in French!!).

But i has 0 capacity: 0 free space, 0 used space.

I tried to format it from the explorer: does nothing. I tried to check: "Properties: removable disk ; filesystem: unknonw.

Then I checked Tools - Check now (still in properties window)

It tells me that Windows has no access to the drive!

I tried to go the computer, manage, uninstall. It gets re-installed, but the problem remains the same.

I tried to plug it in another computer: everything showed up: the embedded software and the files I copied yesterday.

It is made to work only once per computer??

It is made to work only once per computer??”

Try it in that other computer again.  If it works that will answer your question. :wink:

As to the first computer, it could be it needs to be rebooted.  Some systems don’t come out of hibernation well.  It could be your AV or AS apps reacting to the files in the folder you copied to it.  On your hard drive they are fine, on a removable device not so much.  It could be another USB device got assigned the drive letter of the Cruzer while it was out.  A very common situation with Windows.

I changed the letter to an unused one: no change.

If I reboot, and if I have “HP USB Disk storage tool” launched, then it works ONCE (until next reboot). Though that app might make no difference after all, and I’m still not sure this whole thing is not totally random.

While it was working, I tried to copy a directory from the computer to the drive. It took forever, and when I cancelled it, it switched back to drive with 0 out of 0 free space (!?!)

I found a procedure that involved replacing usbstor.inf: didn’t change anything.

I can’t believe a USB drive could be such a hassle on a modern OS in 2012!

When I plug the drive in, nothing happens for several seconds, then the whole computer is not responding for several minutes before claiming the drive has 0 out of 0 space.

The file contains pictures and nothing went wrong when I took them from my mobile phone on usb mass-storage mode (yes, on a different letter).

Is there any place where I can find a log file or alike??


I just figured out under the Computer management/“Peripherals management” (is that how it’s labeled in english?)

There’s a letter showing up in “mobile devices” with same letter as the usb drive (it follows it if I change the letter).

Somewhat Windows7 believes this is a mobile device. How could I enlighten it a bit? (uninstall didn’t work…)

Try shutting down Windows, removing all USB devices not needed to use Windows, ie keep mouse and keyboard, reboot Windows they try the Cruzer.  And without running the HP app.

In that the Cruzer works in the other pc the problem is isolated to the machine with the problem.  It could be a dirty USB port, a conflicting pc configuration, a Windows problem, etc.

I had faced this problem. I found a solution by deleting all the registry key’s related to sandisk. After deleting I rebooted the machine and connected the drive. its working fine for me. But slow.

Pls see the link below:

Hope this will solve for you too.