cruzer 2.o titanium

Hello as you know I’m new to this so I will do my best to describe the problem. When I plugged in my cruzer this am I heard the sound that it was recognized and the light came on but nothing on screen. Went to my computer to see if it was there and no. There is no icon on the task bar but I can click safely remove hardware and it shows both my printer and safely remove usb mass storage device drivers (F E). I went to troubleshot and did check if u3 launchpad is running, starting launchpad automatically, reinstalled u3 and tried cruzer flashdrive could not be detected due to drive letter conflict BUT chickened out when I was about to resign a letter when the warning box came up! Now I am past computer 101 and 102 but when I get into that stuff I get a little nervous. I would appreciate any help at all because this cruzer contains months of data from work. Sorry if this is to much info but it seems like I should give you more and not less

Did you happen to see the top post of this board from only 1 day ago, before you registered and described your problem?

I would offer you the same advice. While you might get some help here, most frequenters of this forum are mainly concerned with their mp3 players, the Sansa line specifically.

You have a much better chance of getting a quick response and more knowledgable help if you direct your question to SanDisk’s other forum here and here.

Good Luck! :smiley:

Edit: Spelling correction

Message Edited by Tapeworm on 03-30-2009 09:15 AM

Thanks I didn’t see the post but after looking at it I’m taking your suggestion and moving this to the other board.

Hope you get your problem solved.

I’m sure you will over there. Don’t get me wrong; I’m not trying to chase you away . . . you are more than welcome here. It’s just that I think you’ll get better & quicker help for your particular situation on the other forum. :wink: