Problem with driver

I have a 64GB Cruzer Force USB flash drive. It worked correctly on three different Windows PC’s. However, for some reason it has now stopped working on one of them. The PC ‘dings’ when it is plugged in and Device Driver shows it has opened the Sandisk Cruzer Force USB Device driver. However, it doesn’t show in File Explorer, so I can’t access any files on it.

Since it still works on the other two PC’s I don’t think the problem is with the drive itself. It must be the driver installed on the problem PC. I have tried uninstalling it through Device Manager, but it reloads and the problem persists.

Any suggestions to fix it?

On the Windows pc having problems with the drive try changing the drive letter assigned to it to something new, using Device Manager.

Thanks.That gave me a clue. Device Manager doesn’t give the option to change the drive letter. However, Disk Management detected the drive, but hadn’t allocated a letter to it. When I did allocate a letter the drive worked correctly.

Excellent news.

Yes, Disk Manager. I wrote the wrong D Manager.