Flash Drives not working

I have had several Sandisk flash drives over the years without any problems until now. Just recently these drives are not showing up on my desktop computer running Win7 64 bit or when they do they are not useable; I have tried everything. When I first noticed this I was trying to drag & drop a file into one of my Cruzer Switch 8GB; kept coming up with this message “Could not find this item. This is no longer on this computer”. However the drive still shows up in  “Drives & Removable Storage”. If I go to Manage and Device Manager the drive shows up and properties shows that it is working properly; obviously it isnt. I have managed to get them going by right clicking on the drive in Device Manager and clicking “Uninstall”; I then remove the drive from the USB Port, re-insert it and “installing new device drivers” popup appears as does the “Sandisk Cruzer Switch installed” popup. The drive now functions as it should; I can copy files and they show up. Once I remove the drive and reinsert it the same thing happens; the drive is no longer useable and I am unable to see any of the files copied to it. Anyone have any suggestions? it seems like the device drivers are somehow unloading but I am not sure that is the case as I can go to properties of the drive in Device Manager and see the drivers installed under the driver tab. Once again as far as Device mnager is concerned “the device is working properly”.

I have also tried these drives (3 in total; 2 Cruzer Switch 8gb & 1 Cruzer 4gb) in both my Laptop running Vist; my Slate running Win7 and my wifes laptop runing Win7; all work all of the time.



After much trolling through previous posts it appears that HTC Monitor Service is the culprit. Have disabled it and everything is fine except now I have to work out how HTC Sync is going to work or not work.