Cruzer edge is detected and istalled but not shown


I have a cruzer edge 16 GB and my laptop doesnt shows it at the my computer but at the device manager it shows.

Tested other flash drives in my laptop and all of them worked, even other sandisk drives.

Can you please help me?

Try a different USB port.  And if that doesn’t help try changing it’s drive letter in Device Manager, removing it then retrying it.

Already tried this.

The problem is that i can see the flashdrive at the disk management but i cant change the letter. It gives me the following message: “the operation failed because the disk management console view is not up-to-date.”

Did the rest of that error msg say something like this?

“Refresh the view by using the refresh task.  If the problem persists close the Disk Management console, then restart Disk Management or restart the computer.”

And did you close Disk Manager and restart it or reboot?

Another step you can try is to uninstall the usb driver, rebooting, then plugging the Cruzer back in.

I did this too, but sadly, wasn’t effective

How about on other desktops, when you plug this in, does it get detected?