Cruzer Edge 4GB Not working/functioning

Recently my 4GB cruzer edge USB is not getting detected on my computers. I have had it 6 months or so and was regularly using it for transfering work between the office (PC) and home (Macbook), however it now is not being recognised at all on my Mac and only partly on PC. I have followed all the steps listed on the site below, but still not functioning properly to allow me to transfer files. On the computer management it appears under the disk drives but not storage options, so it won’t let me format it or change the drive letter. Does this mean it is non repairable or is there any other steps I can take. Please help??

many thanks

Don’t have anything on top of my head here. But try a reformat of at least three PCs and see if all of them would give you an error message on doing it. 

if u hv tried formatting as mentioned on the website n still not successful and ta Flash Drive is still in warranty then its better to get it replaced from SanDisk.

DouglasBotts  please read.