Computer wont install my player!

I recently updated my OS from WinXP Home to WinXP pro. I went to go add some music to my player earlier and it said that my device needed to be installed. I thought, “ok, no biggie” and went through the process of installing it. After installation, it said that problems occured during installation and the device might not work properly. When I looked at the device in the device manager, it said

Device cannot start. [Code 10]

I’ve never had this problem installing the player before. I’ve tried everything I can think of, including installing the MTP kit from Microsoft. I even tried MSC mode. It installs the player, but none of my files are present.

Can anybody suggest anything that could help? 

Try opening Windows Media Player and checking the version, just to be safe.  Click on Help > About and be sure that you have WiMP 11.

Windows XP is bundled with WiMP 9, and the update may have zorched your previous MTP-capable installation.

Good thing you have installed the MTP Porting Kit.  MTP is actually a virtual mode that treats your Sansa as a media player rather than a simple MSC flash drive.  This makes the mode more complex.  One of the differences is the “wall” between files visible in MSC versus MTP, as you’ve discovered.  Files transferred in one mode are not available (on the PC side) when in the alternate mode.

Be sure to set your player back to Auto Detect or MTP before going further.  In fact, for diagnosis, select MTP to ensure the Sansa is trying to “speak” MTP while we delve into it.

Try entering the following commandas described in this post.  It helps in Code 10 issues.

Reboot the PC.

Once it’s done booting, go ahead and plug in your Fuze, and press [Windows Key] + E, or go to My Computer to open a Windows Explorer window.  We want to see if it pops up under other , meaning that it’s in MTP mode.  If it is listed as a media player, you’re back in business. 

If not, open the Device Manager and look for the Sansa in the USB hub.  It will be listed with a wee yellow triangle of doom in many cases.  If so, right click on it and select uninstall.  Disconnect, reboot again, and plug in once the system is stable.

Your Sansa should be happy in MTP mode.

Bob  :smileyvery-happy:

I do have WMP11. In fact, I had just finished installing it when I tried to add music to my player. I tried that little command with no success and I’ve uninstalled and reinstalled it countless times. When I had XP Home, i never had to install the porting kit. It worked fine in MTP mode since I first got the player. I’m at the end of my rope about what to do.

Try the most basic fix once again: manually select MTP mode on the Fuze, and plug in.

Go to the device manager, and find the Fuze.  Uninstall it, reboot, and plug in again.  Have a Windows Exploder window open when plugging in, so you can see if it idents as a media player under “other”.

Another oh-so-fun option is to open the Windows Updater function, since Microsoft hotfixes everything.  I think they wrap everything in a reused brown paper lunch sack over there.

My official opinion: Microsoft designed this monster, and why don’t they have a simple wizard to fix it?  Be patient, as Windows has the funny habit of suddenly “just working”.

Bob  :wink:

Well, I switched it from auto detect to MTP and it works now. I tried doing that before, but it didn’t work. I guess it’s like you said, windows has a habit of “just working”. It’s strange, because it always automatically detected it and ran it in MTP mode with XP Home.


I am also trying to deal with a similar issue.

The Fuze device does not show up in Windows explorer when I am in (my default) MSC mode.

I have switched the USB mode to MTP, and now I can see the device.  (althogh I can’t work that way of course since all files have been added using MSC mode)

My question:  Where is Device Manager?  I ahve tried looking in Control Panel, Accessories and Programs and cannot find it.



I found Device Manager.

I set the Fuze to MTP mode.

In Windows Explorer it now shows up.

In Device Manager it reads as “functioning normally”.  I Disabled the fuze.

Then I rebooted my machine and rebooted the Fuze.

I connected the fuze again and went to Device Manager and “Enabled”.

Still showing up OK on WE

Changed fuze USB mode back to MSC.

Connected again.

Nada. Nothing acknowledged in WE.

Has my Fuze failed?

Wow!  A refreshing inversion from the usual malady here: MTP works, but MSC doesn’t?

Let’s confirm the situation.  When the device is connected in MTP, does it show up as a single media device under other , at the bottom of teh Windows Explorer list?   If so, a double click on the device will confirm it: the device will display as two devices, Internal Memory and External Memory.

If this is indeed the case, unplug the wee Fuze, and select Settings > System Settings > USB mode > MSC, then plug in again.

Watch in that Windows Explorer window if the device now shows up as two drives, under devices with removable storage.

With the Fuze still plugged in, press [Windows Key] + [Pause/Break Key].  Select the Hardware tab, then Device Manager.  Look for the Sansa in the bottom of the Universal Serial Bus Controllers tree.  Click on each one, or look for the wee yellow triangle of doom.  Right click on the troublemaker, and select uninstall , not “disable”.  To disable a device is to tell Windows to simply “ignore” it.

Unplug, reboot, and connect again in MSC mode.  Windows should reinstall the proper driver.

Bob  :smileyvery-happy:


What I HAVE discovered is this is only an issue on my work computer…as of a couple of days ago.

At home it’s not an issue.

Both machines are Dells, with WinXP.

When I get back to work on Monday I’ll go through your suggestions.  I DID get the Internal Mem and External Mem related to the device when in MTP mode.