Sansa Fuze - Device Manager Problem -

Hello All, I’m new here so I hope I’m on the right place.

I got a Sansa Fuze 4 Gig. I’ve just formatted my pc. I installed the Sansa Updater and I installed my Sansa correctly. Everything works fine exept for one things. When I reboot, I get a message from windows that I have a new device on my pc and needs to install the driver but, that is not the case. I have nothing new installed. It started after I installed my Sansa. I’m on Windows XP Pro SP3.  And one more thing, I had to install the “Microsoft MTP Kit” for it to work. Otherwise, windows did not recognise my Sansa. Anyone has a idea why this is appening ?

Thanks :slight_smile:

Windows XP, out of the box, is shipped with Windows Media Player 9.  The MTP drivers for the Sansa are integrated into WiMP 10 and 11, hence the need to update the Media Player.  To update, simply open WiMP, and click on Help > Check For Updates.  Once you have the player updated, you’re in business.

The MTP Porting Kit also includes the essentials for the MTP mode.

Bob  :smileyvery-happy:

Ok for WMedia, I have the version 11 installed no problem there. So it must be elsewhere the problem… To add to my fisrt thread, the first time I installed sansa fuze, windows did not recognised it has a portable device but has a storage device. That’s when I learned here, in a thread that installing the MTP Kit would correct the problem and it did, but after that, I get the message each time a reboot that I have a new device…

Voila !  :frowning:

I have two primary platforms that I use for testing the Fuze and other Sansas.  Both are currently running XP Pro SP3 with WiMP11.  I only use the Vista machine occasionally.  PC number two is the Frankenstein for video; it has codecs galore.  Number One has a “stock” OS and WiMP11.

With Number One, I will occasionally get the “new MTP device” balloon, despite all being OK.  Is this your situation?  After a few seconds, the taskbar clears, and the Sansa is happily talking MTP.

Go ahead and connect in MTP mode, then open the Device Manager.  Let’s do something a wee bit different.  Find your Fuze under portable devices , midway up the tree, and select reinstall driver versus the usual uninstall / reboot / plug-in method.

Let me know if this restores a happy comm session.

The next step I’d venture a guess into would be cleaning the system registry.  There are plenty of choices in this department.  I use Uniblue’s suite, as it’s atomic fast and builds a backup to Windows’ normal registry backup.  I also have had success with Microsoft’s Live One Care firewall / antivirus / backup suite.

The One Care application is the only one that I’ve seen successfully remove spyware and its resulting registry hiccups; I use that on Number Two at the moment.  One Care is currently available at some good discounts too.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 04-07-2009 12:48 PM

Ok I tried your first solution, did not work. When I have my device manager open, and I connect my sansa, windows detects it no problem. I see the Portable device where it should be but at the same time , At the way top of the list I get a Storage Device with a ? mark on it… windows detects that but there is nothing there !.. stupid microsoft &()?%%(?*&)(…

The only problem is the detection of that storage device, by windows, that is not there. The sansa fuze is detected without any problems.

Maybe it is detecting the MicroSD card slot in the Fuze as a separate device. When the unit is in MSC mode, Windows simply sees two removable drives.

As for spyware, why not start with the free and well-trusted Spybot.

Message Edited by Black-Rectangle on 04-07-2009 01:59 PM

NO I think that the first time I installed my sansa, windows tought it was a storage device and kept that information intact even though now he’s detecting a portable device. I’ve installed Uniblue suite 3 and did repairs everywhere on my pc and rebooted and amazingly, it stop asking for the false storage device alert…I don’t know what this soft did but it fixed it ! for now anyway…

Thanks alot bob for your replies ! For now, problem is solved !

Have a nice day :slight_smile: