A different kind of MTP issue than I have read about here

required info:  Sansa Fuze 4GB version 02.03.31A using MTP mode,     PC info:  Self build system, XP home SP3, WMP 11.  AMD FX 60 cpu 2.6 Ghz, 3 gigs ram, ATI gfx card

Problem:  MTP mode and WMP 11 worked fine several weeks ago. Able to sync playlists, charge in MTP mode, PC aslo detected in MSC mode.  No problems.

          Recently when i plug up Fuze MPT mode, i get found new hardware balloon “sanza fuze” then it changes to MTP device then it says “your hardware was in stalled but you need to restart pc or it may not work properly”

          So I reboot (have done this with Fuze plugged up and unplugged in MTP mode)  i get the found new hardware balloon again.  I check device manager and see the fuze listed in portable devices then it renames to MTP device.

           it end up with a yellow mark when it tells me to restart pc.  If I check properties at this point, there is a code 31 “windows cant install device because you have to restart pc”.

          Reboot, same song and dance.    Windows still detects Fuze in MSC mode just fine.  WMP 11 doesn’t ever even know its there if in MTP mode (because Fuze never really installs)

             How do I get it to complete install on reboot I guess would be the main issue, then I expect WMP to pick it up.

What I Have tried:  After reading these fourms and searching the web I have:

                           1. reinstalled WMP 11      (didnt fix issues)

                           2. installed microsoft MTP porting Kit          (didnt fix issues)

                           3. hooked Fuze to an HP Pc using the same cord and WMP 11 picked it up just fine as “Sansa Fuze 4GB” and started sync setup.

                           4. formated fuze and re-tried on my PC   (didnt fix issues)

                           5. Ran win xp SFC (system file checker) from Start/ Run/ prompt. (took about 25 minutes) still same issues.

                           6. system restore to a few days ago.   (didnt fix issues)

                           7. probably a few other things that i forgot and the above list isnt necessarly in exact order.

I have read about the Monkey thing and some about Winamp, but I am really wanting this to work as it should just like it did on the HP machine with WMP 11, just as it did on this pc a few weeks ago.

Things that might be of importance:  Had trouble with old creative soud card and had to attempt to remove completely. still some software junk in there I’m sure but i got most of it.

                                                  Went from xp SP2 to SP3 and lots of MS updates. 

cant think of anything else, sorr to be so long, just want you to be up to date on situation.



People have had issues with Windows XP SP3 and MTP mode on the Fuze and Clip+. Some have reported that uninstalling and reinstalling Windows Media Player 11 have solved these.

Message Edited by TomJensen on 05-03-2010 05:53 PM

Ok Tom, i will give it a try and post back the results.

Thanks for the find

Well thank you a bunch. Reinstalling the UMDF files fixed the problem. I have been working on this for most of my free time for the past several days.

I am going to go back to the link you posted and add a few notes to the method given there. I was unable to find certain files the way he described it, but i want to share how I did find the files for others that were like me and couldnt.

after doing the fix, I pulled up WMP11 and hit sync tab, hooked up Fuze and the PC and WMP picked it up right quick and I’m back in business.

Thanks again Tom.