Computer will NOT "see" either of two Sansa Clip Zip devices

I thought my “old” Sansa Clip Zip player went bad when my computer would not see it when plugged in. I bought another one today. Computer does not see that device either.

Any suggestions. My old device has V01.01.20A and the new device is firmware V01.01.21A.



These things come set from the factory to Auto Defect mode as the USB setting. Try MSC mode (Settings > System Settings > USB Mode) and see if it will connect.

If that doesn’t work, you might try de-auithorizing the Clip under Device Manager (if you’re on Windows) and then re-connect up–this forces Windows to try to set up a new connection from scratch.

Guys, before posting I tried all your suggestions first (I read them on the forum prior to my first post). Nothing worked. Then I plugged both units in (at different times) into my wife’s computer. That computer recognized the devices. I then replugged them in to my computer and now that computer “sees” the units.

I don’t have a clue how they got fixed, but both units are now functioning properly.

Go figure…


Congratulations!  And I know the frustration feeling, having spent over 2 hours on the phone with a Microsoft tech. today (over a brand new computer and issue, no less)  . . . .