Computer recognizes sansa clip+ 4 GB but it won't turn on?

My Sansa Disk player won’t turn back on? I plugged it through the USB and my computer recognizes it just like it normally does but now there’s no output from the LCD screen.  When I try to turn it on it won’t work either (no matter how long I hold the power button).  any ideas?

i also tried installing the newest firmware. still no dice.

You can try to reset the Clip+…

Resetting a Sansa player

My Sansa Player is freezing up. How do I reset my Sansa player?

If your Sansa player is freezing or not turning on, the first thing to try is a reset. This will clear any temporary condition that may cause the player to freeze or not shut off completely.

Resetting a Clip Zip, Clip+, Sansa Fuze+, c200 series, e200 series, or e200R series player:

  1. Press and hold the Power/Menu button for approximately 20 seconds.
  2. Release the Power/Menu button.
  3. Press the Power/Menu button again to turn on the player.

One other thing to try if the above doesn’t work, press and hold in both the Power button and the Home button for at least 30 seconds. Release both buttons, the press the Power button to see if the Clip+ turns on.

are the power/menu buttons the same? or am i pressing both ? which one is the menu button?

well, i’ve tried both holding the power button for over 30 seconds and the power button and home button at the same time for over 30 seconds. no luck

It appears some people have had luck reviving a Clip+ that refused to power on by pressing the power on button followed immediately by pressing the home button.

No luck.  I just don’t get why my computer can recognize it but it won’t turn on visually. 

Possibly the OLED screen has given out. Is it still under warranty (1 year in US, 2 years in EU)? If so, Sandisk should replace it free of charge. If not, then just buy a new player.