sansa clip+ wont turn on

ok so i just bought this thing yesterday

i went to use it for the first time today

i fully charged it and loaded it up with music as well as a micro sd card

at work i started to use it for the first time and a few songs later it shut down

i didnt get it to turn back on until a few minutes later i removed the sd card and reinstalled it and it turned back on 

a few songs later it did the same thing

and the same trick turned it back on

a few songs later it did it again

and now it wont turn on whatsoever

i have tried holding the power button for thirty seconds and nothing

i connected it back to the pc i used to charge it and load it and sometimes it says driver install failed

or it will say i need to reformat the disc, sounds like a bad idea to me so i didnt reformat

then i downloaded the firmware update software and that wont recognize the player

now i work in a factory and today was like 85-90 degrees farenheit 

and i had the volume at aproz 3/4

did i overheat it?

this thing had great reviews and i really liked it cuz of its size and folder browsing and sd slot

i think i will exchange it tomarrow at the store for an identical unit and hope that mine was defective cuz i like this products features alot

and tips?

i must say this experience was dissapointing to say the least and if the new unit does the same thing or if this simply cant take the heat i will just have to go with another brand and hopefully i can find one with the same features

i almost forgot

if it matters it is the 4gb model

and the sd card is a SanDisk micro sd hc 4gb

I don’t have an answer for you.  But I had a similar experience.  Little bugger played for 7 hours, then kaput.  I did try the reset and recharging instructions listed in the support section of ths site…but it’s still “unresponsive”  I was hoping there was an answer here for you that  may help me as well.  Best of luck.

Just found this and it at least got my clip+ to turn on and be recognized by the computer.   Will see if it plays the music.

Here’s the link: 

Just found this info …here’s what worked on the clip+:

Good Luck.

Have a Sansa Clip+ 4gb with a Sandisk 16gb microsd card that suddenly wouldn’t turn on yesterday. And it refused to charge and a computer could no longer see it as an external device/drive. I think I may have inadvertently briefly hit both the “Power” button and the “Menu” button at the same time. Left me scratching my head as to why is suddenly stopped working and would not charge. The Resetting a Sansa player link previously posted brought it back to life. Note I did remove the microsd card before resetting. There doesn’t appear to be any loss of content on the player. Don’t know why hitting those two buttons for a brief second would cause the unit to no longer charge nor power on.

@jared8783 wrote:


i think i will exchange it tomarrow at the store for an identical unit and hope that mine was defective cuz i like this products features alot


This is probably a good idea, or call SanDisk Tech Support if your dealer gives you any problems.

well last night i got it fully functionable by holding on the home button

i will take it to work with me again today and if it gives me anymore trouble then it is going back to the store 

If someone else has this problem, when they can turn on the player, reformat it using the player’s menu. I think some of the sample files that come loaded on the player may be corrupted. Reformatting the player will delete all songs loaded on the player, so make sure you have those on your pc before reformatting the player.

I don’t believe that the sample songs on the player are corrupted, at least originally.  One would think that that issue, if it existed, would have been detected over the past couple of years. 

Perhaps, but then again, perhaps not. I seem to remember having some issues with both my Clip and Clip+ initially, but they were fine after I formatted them using the player’s menu. Whether it was corrupted sample files, or some other factor, formatting them via the player menu got them working just fine.