Clip Zip not recognizing all music on SD after months of the same content


I have had a clip zip 4gb for some time now, like 3 months or more. i haven’t added any music since before the newest 1.01.20 firmware update. A few days back my clip zip froze at the end of a song, when it should have changed tracks. i had to hold the lock button to turn it off and back on again. this seemed to fix the issue, but it kept happening more and more. also, sometimes when the song would end, i would try to press the next track button to goto the next song, and it owuld just start cycling through many many songs in a row not playing any. then i realized that the player was not recognizing all the songs on the sd card. In fact, the card doesn’t work the same way twice in the player anymore. sometimes it will see only artist 0-9 and A-C, when i look at the card content not in the clipzip device the 10 gigs of music i have been using since i got the thing are still present. I had not even removed the card since i got it until today when i started troubleshooting.

I tried manually reinstalling the firmware, but i still get the same issues. it’s only usually recognizing about 3 gigs of the songs. as i stated, i have not changed any content recently aside from the automatic firmware update and the manual reinstall of the firmware i recently tried. 

after some more testing it seems like it’s the sd card. i was able to see the files in windows, but when i put the sd card into my phone it said it was corupt. i tried reformatting with win 7 but i think the card might have died? is this possible?

Yes, it’s possible. What kind of card is it (Brand, Size, Class)?

1 Like

this is the card i have

after spending a few hours researching and testing, i am almost certain something is wrong with this card. I kept gettingerrors drag and dropping files saying the volume was write protected. it seems like everything works fine, files were showing up, etc, so i tried copying a 10gb folder of music to it, and it was taking FOREVER. the estimate was like 23 hours to copy, and stayed there for a long time. I formated the card in the clipzip, in win7, and now i have just formated in my samsung galaxy s3 and tried copying a folder of music to it and it gave me some error which i stupidly lost the text, but was something to the effect of file details have changed since it was opened?

anyway, right now i have unchecked the “quick format” option and am formatting again in win7. i dont have much experience with micro sd cards, so when it started acting funny with no changes to it’s environ, i thought it was the player at first, but the player seems to play off of it’s internal mem just fine.

EDIT - after having win 7 format without the “quick format” box checked, it took like 20 or so minutes, then spat out “Windows was unable to complete the format” error box. so i guess the card is dead?

It could be.  You also might try reformatting the card using the SD Association’s Formatter tool–it sometimes can fix “unfixable” issues. 

The card you linked to is a 32GB Class 10 card. Many people have reported problems using Class 10 cards in mp3 players (particularly in this case the Sansa players), and phones. Class 10 cards are designed for use with cameras (still and video) where high-speed writing in needed. This post explains it more in detail. It’s basically a matter of using the wrong tool for the job at hand.

Whether the card is defective or you’re running into this compatibility issue, I don’t know but it sounds like a new card is in order. SanDisk should probably replace it under warranty, but if you get another Class 10 you may run into the same thing again. Class 4 cards are a better choice for your Zip.

Is there anyone to get a 32Gb class 10 micro SD card to recognise in this mp3 player? I’m currently have the same problem, I’ve only formatted the card though with a computer running Mac OS and another running LMDE.  

Is it a problem with the formatting of the card?

Answered in your other post:

okay, thanks =)