Clip Zip freezes at startup flower logo with MicroSDHC inserted

Hey all,  

I ordered my 4 gb (orange) Clip Zip direct from SanDisk (the sweet promo with the case, of course) and received it yesterday. Loading music onto the internal memory was foolproof. I updated the firmware right away. I was eager to use a 4 gb SanDisk Class 2 MicroSD card my brother gave me, so I loaded it to max, turned the player off, and put it in. When I turned it back on, I couldn’t get past the flower logo. If I hard resetted the player, took the card out, and turned it on again, it worked fine, but trying the card again proved fruitless. The card can be read from my computer using a SanDisk SD adapter but I couldn’t reformat it in the player because plugging the player in with the card inserted would make it so my computer wouldn’t even recognize the device.  Even when completely EMPTY, in both the internal and external memory, my player refuses to read the card. I’m a Windows user.

I’ve done a lot of digging on this forum, the Anythingbutipod forum and Google to try to find an answer to this problem, so I’ve tried a number of methods already.

Here is what I’ve already tried:

  • I reformatted the card in the SD adapter. I used the regular right-click format, using “Quick Format”, when that didn’t change anything, I used the SD Association’s reformatting tool on Full, and when that still produced nothing I used Disk Manager on Full.
  • I reformatted the player, using the player’s internal “Format” command.
  • I re-installed the newest version of the player’s firmware manually, following all instructions.
  • I also tried a 2 gb generic brand MicroSD card I had kicking around. Exact same result, and I can even read that card on my computer with the same adapter.

Is there anything else I can do to make this work? Is it possible this is cause by some firmware bug to be fixed in a future build? I’m getting pretty sick of having to return technology almost immediately after I purchase it, and other than this one, albeit big issue, I’m very happy with the Clip Zip.

Thanks very much in advance.

Dang, you’ve done everything I can think of, apart from a reset (hold the on button down for 15-20 seconds or more)–but I doubt that would help.

Perhaps phone SanDisk up, possibly for a replacement?  In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:

Miikerman, I’ve already put the claim in. Unless someone else has a “why-didn’t-I-think-of-that” solution, I plan to follow through with it. :confused: Bummer…

Hold the power Button for an entire minute. See if that helps.

ConversionBox, I turned it off, put the card in the drive, then held the power button for 60 seconds. It was still stuck on the flower icon, so I held it for another 60. This turned it off, so I turned it on again. No change.

UPDATE: SanDisk has agreed to replace it for free. Besides the waiting time, the only downside is that they could only replace it with a black player; a bit annoying since I really liked my orange one, but I guess it will match the Rockbox scheme a bit better when the port is finished.

Sorry they didn’t have an orange for you, but nice to hear that you’re fine enough with the black, in the end.

I guess we now know what the hot-selling color is–already out of stock!

Hi all, 

Just as an FYI I was having this same problem and found this thread regarding the freezeing problem. The 4 gb card I was trying to use was pulled directly from an older Sansa Zip and was formatted and working in the old player. I was about to give up when i tried a smaller micro card laying on my desk and it worked! 

I compared the two and discovered that my 4GB card was formatted Fat 32 while the other card was not. After reformatting the 4BG card to just “FAT” it began working in my player. 

best of luck to anyone else having this problem.