My ClipZip has stopped reading SD cards

Hi.

My 4gb ClipZip has stopped reading SD cards. It was able to do this fine until a few days ago when I used a travel charger to charge the device.

The ClipZip plays music from the internal memory okay, but it now freezes on the “refreshing your media” screen when I insert an SD card. I hope the charger has not damaged the device. I have tried resetting and restoring the settings several times.

Any advice??

hi.

I also have a problem as you, and I figured out how to solve.

Your  MicroSD card may contain some faulty tracks (tag, code,…). you just delete them, redownload other tracks or reconvert, edit tag,…

Good luck. :smiley:

It also may help to reformat the card. The SD Association has a card reformatter tool which often works well in fixing issues. https://www.sdcard.org/downloads/formatter_3/

Thanks for your advice. The player can’t access ANY of my SD cards, though. My two Sansa Clip+ players and my Sansa Fuze can access all of my SD cards with no difficulty so I am a bit concerned about my ClipZip, especially as it worked fine for the first three months or so.

I should also say that I recently had to install a new hard drive in my laptop PC as the old one was worn out. Therefore, I had to start from scratch and reload all my system recovery discs.

I connected my ClipZip to my “new” laptop recently, too. Could this have affected my ClipZip? Is there anything I can do to fix this problem? Would reinstalling the pkayer’s firmware help?

How about, then, reformatting the Clip (after saving your content to your computer) and/or reapplying the firmware (see the firmware upgrade sticky thread above)?  Those can sometimes solve issues. 

Yes! Removing content and reinstalling firmware has helped a lot. The player can now read and play SD card content, although it does tend to take longer than before to access the card and to switch on. Also, the firmware version is now 01.01.20P rather than 01.01.20"x".

Thanks for reporting back and noting that the “good, old, reliable” solutions are still that. Did you also reformat the player, or was it the firmware reapplication that fixed matters?