New Micro SDHC card reads as empty in Clip Zip after refreshing


I have a fairly new clip zip and a brand new san Disk 32G SDHC card, class 4.  I started loading music in it by directly copying folders onto the card while in my laptop.  When I insert the card into the clipzip, it refreshes the files, but if I try and access the card either through the card menu, or folders on the music menu, it shows everything is empty.

Anyone have any help?


I think if you want to use an external card reader (like on a laptop) you need to have the player in MSC mode. Try switching it under settings and see if that fixes it. (I could be wrong, never used MTP mode at all)

The Clip Zip can locate all files on the card, regardless of mode of transfer used (MTP or MSC), but the device’s USB controller will show only one mode at a time when accessed from the PC (Sansa plugged in).

Using a separate card reader, the card will generally be accessed as an MSC device.  The Clip Zip can access the card in either mode.

If no files are showing when accessed from the Clip Zip (unplugged), try transferring a single file to the card using the Clip Zip as the reader.

MicroSD card compatibility was addressed in the latest build of the Clip Zip’s firmware.  If you havent done so yet, update the Clip Zip’s firmware using the Sansa Updater, or by following the steps in the firmware threadhere.


Did you put the card in the player when it was off? Inserting a card in the player when it is on can cause issues.

Saratoga, Thanks for the suggestion.  It was on auto detect, but I tried again on both settings, and no change.

I did put the card in when the device was off.

The card is a Sansa card, and is formatted FAT32

I just successfully updated the firmware, and still no change.

When I was putting files on the card, I was just using Windows explorer.  The files are in a folder heirarchy as so: Artist/Album/* *.mp3 files

I tried first copying the entire folder structure for each artist, then tried just the song folders, to see if that had anything to do with it.  Will the ClipZip read the folders heirarchy?  Do I have to just copy individual files?  That seems silly as then, i would have no filing system on the device.

Any other suggestions?

Are the tags ID3v2.3 ISO 8859-1? That is what the player needs.

Sorry - I don’t know what tags are in this context or how I would know that.

Extra! Extra! Read all about it:

ID3 tags

Thanks for the link but that is gibberish to me, really. :)  The tracks I have put on the internal harddrive work fine.  Also, I am not even seeing the file structure - artists/album folders - when I try to read the disc in the Clip Zip.  It just shows as [empty].

Does anyone know for sure when putting tracks on a card to read in the clip zip, whether you add artist and album folders?   Woudl that even matter with my current issue?

Did you use Windows Media Player to rip the songs from CD? If you didn’t change the settings, it will rip to protected WMA. You should change the settings to have it rip to mp3, and choose at least 192 for the bitrate for decent sound quality(I use 256 kbps). If your songs were ripped to protected wma, I suggest you rerip them to mp3 and use at least 192 kbps.

Are these mp3 files, or in another format the player supports? If they are protected WMA files, they need to be transfered to the player using Windows Media Player, or another media player that transfers the licenses, and you need to use MTP mode to transfer them.  Loading protected wma files directly on the card in the pc will make them unplayable.  Some protected music(especially subscription music?) might need to be in main memory and not card memory to be playable.

If files are too deeply nested(ie. folders in folders in folders, etc.) the player might not see them. How many songs do you have on the player? They claim an 8,000 song limit, however if you have long tags, or path names, the limit might be much lower.

I don’t know if you’ve got it working or not yet, but the same thing happened to me when I first got mine. I ended up taking the card out, turning the player on (without the card), turning the player back off, putting the card back in and turning the player back on. This worked for me. I’ve since added music to the card by plugging it into my computers USB with an adapter and put the card back in the player and never had a problem. Just make sure the player is off before you put the card in.


I have the same problem as the OP I’ve just bought a 32GB Class 10 Samsung microSDHC card and the player recoqnizes it, puts some folders on it, yet it doesn’t recoqnize any of the misc I’ve put on it. I’ve used every type of transfer method, saved the files to different folders and locations, tried resetting, re- installing the newest firmware, restarting while card is not in the device etc. still no use. Yet the Zip sais that there’s a 29GB card is in the slot and that it has only 27GB free space. I completely doubt that the problem is with the card. I bought it from a retail store and the Zip also did not recognize music on my old 256MB microSD card. It’s a quite aggrevating and annoying situation. Any suggestions appreciated.

The Clip Zip has some compatability issues with some cards not made by Sandisk. I haven’t heard of these issues occuring with Sandisk cards.

@jk98 wrote:

The Clip Zip has some compatability issues with some cards not made by Sandisk. I haven’t heard of these issues occuring with Sandisk cards.

I have. There have been others posting here who have had problems with a Class 10 card. I don’t know whether it’s a speed issue or what, but there have been recognizing problems, even with SanDisk brand cards.

Not that it “fixes” the issue, but using a Class 10 card in these things is massive over-kill. Anything over a Class 4 is a waste of money and from what we’ve seen could be asking for problems.

If not yet done, you might try reformatting the card with the SD Association’s Formatter tool–that sometimes can help. 

Personally, I think a Class 10 card is great for the Clip (nice for file transfer when put into one’s computer), as long as it didn’t come with premium pricing …

Hi all - I did finally reformat the card and now it works just fine, so I guess it was that simple!

Thanks for your help!

I am having tons of trouble with my sandisk 32 GB class 4 card as well. I can’t even get the CZ to show on my computer now. Assuming I do though, how did you reformat it?


I don’t know why it wouldn’t show on the computer, but I followed the directions SanDisk tech support gave me:

Open the My Computer window, right click on the card as it appears as a drive and choose format.  not sure what you can do to make the computer see it, though.

Good luck!

Or, using the SD Association’s formatter tool, start it up and follow its steps (which are fairly easy to do). 

Sorry - what is SD Association’s formatter tool? Thanks.