New Micro SDHC card reads as empty in Clip Zip after refreshing

I have the same problem with one of my microSD card and it is only a 2GB card.  I tried formatting it with the player, then load a podcast onto it, but still it shows empty.

I feel your pain. I have had incredible problems getting mine to work. I was on the support chat with a tech person yesterday, and seemed to know more than him about these things (and that is scary, because I only know what I know from reading these forums and trial and error - literally tens of hours spent on this). But try this, as it is what worked for me (absolutely no guarantees about what will happen, I just rolled the dice, but as I said it worked. reformat the card, turn off the player, take out the card, then put it back in, turn it on, and see if it gets recognized. Like I said, I was on the chat line with a tech person yesterday, and we were going through a bunch of things and he was stumped, so I suggested this and he said “sure, try it out” and it worked. Best of luck.

Wrong!  latest ClipZip firmware “update” 01.01.18A has serious compatability issues not just with cards NOT made by SanDisk but with SanDisk’s own Class 4 cards MADE by SanDisk.  Specifically, it disables using any external memory for Playlists in both Windows Media Player and Rhapsody, and not a **bleep** thing can be done about it.  01.01.18A won’t even allow you to backtrack and load older 01.01.12 firmware on the ClipZip.  Once you’ve loaded 01.01.18A, you’ve effectively trashed use of external memory for Playlists and you might as well forget about that external card slot in your ClipZip.

I am not sure about some of the things you wrote re playlists, but all I can tell you is that the player does now recognize the files I have placed on it. But I have a question of clarification, which will once again reveal my ignorance: To what exactly are you referring when you say playlists? That is, do you mean that you have specific playlists that you have constructed and then downloaded on to the player (say, for running, etc.)? Or, are you referring to the Artists,  Albums etc. lists that allow you to navigate through your music once on the player. I ask, because I would like to construct the former but haven’t gotten around to figuing out how to do it yet (I’m still in the process of converting all my music to mp3 since, contrary to Sansa advertising, the CZ does not seem to be enamored with aac files). Thanks.

I have the exact same issue with the now eliminated option of having the player support Playlists on the external slot.  So for me, this player is a piece of junk now.

So, just to confirm (an maybe save me some time), are you saying that you tried to import a playlist (say, for exercising to), and that the CZ will not read it as a playlist? Just wondering, as I was about to get to doing this kind of thing. BTW, if the firmware is the issue, there does seem to be the option of installing Rockbox, although my impression is that it takes a bit of computer savvy (somethig I lack). Best of luck witht his. I think we can all agree that Sansa should upgrade thier customer service.

@divingduck, here’s my issue.

I’ve tried two mechanisms to transfer a playlist to the external slot:   using WMP or Rhapsody (which I use heavily).  The playlist transfers “fine”.  The problem is that the Sansa Clip Zip player will not list the playlist on the player’s menu, either under Music or Card.   (The tracks are there, and you can play them, but they won’t be organized as the playlists that you transferred).  To me, this is a deal breaker for what I want the player for.  I use playlists frequently, and this just kills my use of the slot.

BTW, on earlier firmware versions, this worked just fine.  According to Sandisk support, they “never wrote anywhere it should work on the external card”, so the fact that it doesn’t on the current firmware is not a bug to them, it’s a design feature.  Nonsense.

(P.S. I can’t use Rockbox because it doesn’t support Rhapsody.)

The Clip Zip firmware can be reverted to a previous build if desired by manually installing the version you wish; I have tested downgrading from version -18, just to clarify that.  EIther manually, or using the Sansa Updater, the latest build can be reinstalled as well.

If playlists are your cup of tea, I strongly suggest MTP mode for ease of use.  If the microSD card is installed in the player, you can easily transfer the desired tracks to the card by selecting External Memory using WIndows Media Player or Windows Explorer.  MTP mode allows building playlists via a simple right-click on your first track, then drag and drop your files into the list.  You can then name the list for access whenever you like.  The problem with playlists that are built for the external card is that the playlist must be resident in the Internal memory in order for the list to be accessed by the player.

In MSC mode, playlists are path-specific, meaning that they have to be within the same folder as your files, as M3U format lists.

Version 18 has enhancements to better recognize the microSD card.  If a card is not recognized, try removing the card and restarting.  If the player sees the card, you will see “refreshing database” on power up.  I have also tested “hot swapping” the card with the device powered up.  Upon inserting the card, the “refresh” message should immediately pop up as the Clip inspects the card. 

Update: As curiosity has always been a close friend, I had a go at building some playlists for the microSD card.  First, the John Wayne method, trying a quick build using MTP and Windows Explorer.  No joy.  There are two problems with this, the biggest one being MTP and a microSD card: there are plenty of reference files added to the card to speed up access.  Navigating in the mess manually is not for the fainthearted.

Right then, off to plan B, let’s try WIndows Media Player.  SImple.  Click New Playlist and drag the desired tracks to the list.  NOTE, like in Windows Explorer, you’re not really dragging music files into the list, you are adding references to those files.  Specifically, I chose five files that are already loaded onto the current mounted microSD card, and one orphan file that is not on the card.  During the Sync operation, Windows Media player sent a new playlist to the device, which I unceremoniously named, wait for it…“Test List”.  I know, how boring a title, but it is a test, right?

Windows Media Player does many things in the background.  The playlist works fiine, referencing the existing files on the mounted microSD card. And the orphan?  Windows Media Player knew that the file was not on the device, and transfered one track to it.  Going to “Recently Added” on the Sansa, the single track is at the top of the list.  The other five are not in this list, confirming that no other music files were transferred.

Bob  :smileyvery-happy:

I agree-it’s nonsense.The way they advertise the product it certainly makes it sound as if the expandable memory integrates seamlessly with the player, which should include playlists.One can only hope they’ll get it together and fix this problem soon. To be frank, if I had known that these types of (at least seemingly) simple things would be such issues I woud have stuck with ipod. Yes, it’s overpriced, but at least it just works (which, whatever you think of Apple, goes for the rest of their products, and I’m no fan). In the meantime, I guess you still have the 4-8 gb of space on the internal memory to work with, although it’s not much consolation.

I was referring to Playlists created in Windows Media Player and in Rhapsody.

It’s not just that it won’t read it as a Playlist.  The firmware won’t “read” anything at all on the micro SD card.  Even though you might have moved tons of MP3s to the card, the ClipZip presents the card as totally empty.

The microSD card has a list of files in the File Allocation Table (FAT), logical names assigned for the Windows OS.  This table can become corrupted at times.  Either using a card readed (the card will be seen in MSC mode), or by ucing teh Zip as the reader- as long as you are connected in MSC mode, use chkdsk  (DOS prompt) on the card, or using Windows:

Open a Windows Explorer window, and select the card (or the microSD card listed after the Clip Zip), and right click on the device.  Select Properties, then click on the Tools tab.  At the top of the list, under Error Checking, click on Check Volume For Errors.

Two days ago, I killed the FAT tweaking a card, also mounted in a Clip Zip.  I was trying to give the device a hard time, and succeeded.  Upon connect, I even scored bonus points, as Windows asked if “I’d like to format the card before use.”  Wow, now that’s a proper job of it.  The FAT was easily recovered using Check Volume For Errors.

Check your card using the player itself as well, go to Settings > System Sttings > Info and see if the microSD card is listed.

Lastly, install the card with the device on, and see if the database refresh pops up as the card is mounted.  Let me know what happens. 

Bob  :wink:

@neutron_bob, Hi Bob, for kicks I tried this one more time, and just like before, although I can get a playlist to transfer w/ WMP (using MTP mode), the tracks make it there, but the playlist is nowhere to be found on the Clip Zip’s menus.  The playlist .refs file is on the sdcard, but there is no .pla file.   And according to Sandisk tech support, this should not be a feature, which is quite an ironic statement since it used to be a feature on a much earlier firmware, and other players on the line apparently support this.  I believe it’s a bug, but Sandisk refuses to acknowledge it as such.

the bottom line is if I can’t use playlists on the sdcard using Rhapsody or WMP, then the player just doesn’t work for me.

@partymonkey wrote:

 

And according to Sandisk tech support, this should not be a feature, which is quite an ironic statement since it used to be a feature on a much earlier firmware, and other players on the line apparently support this.  I believe it’s a bug, but Sandisk refuses to acknowledge it as such.

 

Despite what the customer service reps have told you, SanDisk is aware of the Zip model having some troubles with playlists and are working on it. There has been no word however when an update that will fix the problem will be released.

That’s strange.  The playlist is always resident on the internal memory in the playlist folder.  The test one I just built is there, along with the Rhapsody Channels playlists.

If I understand correctly, are you trying to send a playlist to your Clip Zip, and the list is not showing up under Playlists when trying to locate it, while using the Zip?

Granted, there is one situation I would like to have, and that would be the capability to keep a resident playlist on the individual microSD cards for ease of use.  This way, I could have playlists that show up on the device customized for each individual card.  Say, a playlist of my favorites on each card.  Is this what you are trying to do?

I have made it a habit to store a note (text file) on individual cards with details about the collection on it.  Usually this is detail on the encoding used, etc, for reference, since I have various codecs and formats for testing.  Using the Card node in the main menu, I browse the card to remember which one I have.  The little monsters are so small, writing notes on the shell is not possible.  It would take a very sharp Sharpie pen.

If you are building a playlist using WiMP, and it is not showing up under Playlists on the device, the culprit may very well be Windows Media Player.  I have heard of others trying to build lists and the player does not show them, but this most often occurs in the realm of M3U lists and MSC.

You can try reassociating the device with WiMP.  I have deleted the wmpinfo.sys file before, allowing the media player to build a new association.  Just like Windows does, WiMP sometimes picks up bad habits, and remembers which device it wants to keep those “bad habits” with.  Using multiple Sansas (I have a collection of them registered), WiMP11 would do this, going wonky with one device, but the others were fine.  WiMP12 fares much better in this regard,

Bob  :stuck_out_tongue:

@tapeworm, I really hope you’re right, that is music to my ears.

@bob, yeah, the playlist file is not there (.pla), only the .pla.refs file, and it is being put on the sdcard.  I’m using WMP 12 (the one that comes w/ W7, and firmware 18A.   BTW, I’ve reformatted more times than I can count, I reinstalled the firmware, etc.  I just don’t know what else to do.  It’s the same problem others seem to have, but it sounds like you don’t have it.  However, both Rhapsody and WMP lead to the same result.