SD Card remains "empty"

I have a Sansa Clip+ with a Samsung 32gb micro SD card. The problem is that even after adding mp3’s to the card it still shows up as “empty” in the sansa clip. The card is formatted as vfat and I have tried it on both Linux and Windows. It did work once - but not again. There is a folder at the card’s root called “MUSIC”; inside that there is AUDIOBOOKS and PODCASTS; I have placed mp3’s into MUSIC and at the root of the card - nothing; I have also created a folder called MUSIC inside the MUSIC folder - same thing; nothing. I have tried this directly through the Sansa device and through an SD card slot on my netbook. I really don’t know what to do… Cheers.

Formatted as vFAT? It is supposed to be formatted as FAT32.

Sorry; I should have been more specific - here are the specs:

$ file -s /dev/sdc1 /dev/sdc1: x86 boot sector, mkdosfs boot message display, code offset 0x58, OEM-ID " mkdosfs", sectors/cluster 32, Media descriptor 0xf8, heads 64, sectors 61313024 (volumes \> 32 MB) , FAT (32 bit), sectors/FAT 14976, serial number 0x5d85da3, label: " "

$ find /mnt/sd/ /mnt/sd/ /mnt/sd/MUSIC /mnt/sd/MUSIC/PODCASTS /mnt/sd/MUSIC/AUDIOBOOKS /mnt/sd/MUSIC/01. And I Love Her (alternate).mp3

As you can see it’s formatted as FAT32. The basic directory structure was also created by the device itself which shows that the it recognises, and can write to, the partition. As you can see only a single 7MB mp3 resides as the root of MUSIC. The SD card shows on the device as empty. I must stress that it did work once but not again. I must also stress that regardless of operating system / computer I use - they can all read/write to the card.

This is most likely an issue with the device itself. In system settings it shows the ‘version’ as V01.02.15A - I assume this is the firmware version.


On the player itself you can’t find the songs, or do you mean when you connect the player to your pc you don’t see the songs in your player on your pc?

How did you add the songs to the card? Did you check to make sure the songs are on your card?

Did you insert the card while the player is off? did you insert the card in the player until it clicked into place?

Did you try to navigate to MUSIC> folders on the player and see if your songs are there?

Are your songs properly tagged with ID3 V2.3 ISO 8859-1  tags?

Same here. Just got a 32gig microsd class 10 from newegg. I have a  clip 1g, clip+ 8g, clip zip 8g, and recently a new white sansa clip+4g . 4 in all. I always liked the white one,  [just for the looks, but also prefer the firmware to the zip] so I finally got one, opened it up; I popped in a 32 gig card. Wierdest thing. The folder structure is created, ie music, audiobooks, podcasts; but the player still sees the card as empty. You can add music [or any files] to the 32 card and it works perfect on 3 of my computers,plays the music fine; and heres the wierd thing, it works on my clip, clip zip 8g, clip+ 8g, but NOT on my white clip+4g. Yes I did the sd formattter,,  yes I did the H2testw 1.4. You can even add, read, play files through the player’s card when the player is connected to the computer. A 16g, 8g and 4g microsd work just fine on it.

I am a veteran user, but rarely post. This is definetly a WTF issue. Could be the player, but I guess it could be the card.

I’ve seen all the post for the 32g microsd class10 and very similar issues. All my players have the most updated firmware. The card did not work in the clip+4g with the old firmware, nor the newest firmware [which I guess is not really new]. Now, do I warranty the card, or warranty the player? I wonder if a different 32g card would work, but the strange thing is that it works it my other clip players. I post this because I hope this helps the users see the extent of the strangeness of the issue with the 32g class 10 card and clip+'s. Maybe some were made at different times with different software…who knows. The gurus rock by the way on the posts. You usually dont have to post, cause they have already answered someone with a similar issue you have. Just my 2 cents.

Which firmware does it have? Try downloading the latest firmware(even if it is already on the player), and manually install it on the player. Sometimes the firmware in the player becomes corrupted.

Some other people have had issues with some class 10 cards in the Clip+.  I recommend using class 4 cards.

In the release notes for the 01.02.16 firmware- “Supports newer memory configuration”

I’ve done all as suggested here - made sure it was connected properly ect. Like I said, directories were created by the device, there are definitely media files on it, the device itself also recognises the SD card. The card is a class 10 32GB samsung. I have done a manual firmware upgrade, upgrade went fine, using version 01.02.16P - The problem still persists.

How did you add the songs to the card? Did you check to make sure the songs are on your card? Both through the device and a separate adapter - both on Linux and Windows. Did you insert the card while the player is off? did you insert the card in the player until it clicked into place? It was off and it clicked. The card is recognised, just not the data on it. Did you try to navigate to MUSIC> folders on the player and see if your songs are there? That’s what I done. The card shows as empty. Are your songs properly tagged with ID3 V2.3 ISO 8859-1 tags? Yes, I done a directory listing, there is only one media file on it and the only special characters it uses is a whitespace, . and ()

Anybody got a solution for this?

Probably not a solution; I have a same situation. Some 32g microsd class 10 are incompatible with some clip+'s. I know because I have the same issue. I have a 2 clip+'s and a 4, 8, 16g work on both. The 32 works on one, but not the other.

Don’t know why. What brand is your card? Maybe we got the same messed up issue.

It’s a samsung class 10; not sure of the exact model. Can anyone recommend a working 32GB uSD card?

Mines a Gskill 32g class 10. Does not work on the clip+ 4g. But works fine in a clip+ 8g, and fine in a clip zip 8g.

All my clips are new, not refurbished. Very strange.


posting here, because the problem is the same.

Bought a 2GB Clip+ two months ago, and I’d been really enjoying it. This is THE player, I thought. Until recently, when I wanted to listen to a FLAC collection which wouldn’t fit in player’s internal memory and I bought a card. I was really expecting it to be as simple as pluging the card in and listening. However, this resulted in a total frustration because I was not able to make the player see files on the card.

At first, the player used to lock at “Refreshing your media” screen, and couldn’t even be turned off. The only way to make it responsive again was to remove the card. After some reading here, I created a folder called “Music” and placed an mp3 file inside it. Now the player was able to go through “Refreshing your media” screen, and main menu appeared. When going to “Folders”, the player lets me select the card, but it shows it as empty, no matter what.

Player is Clip+ 2GB, firmware 01.02.16P

Card is A-data 8GB microSDHC Class 2

Card was formatted with SD Formatter.

I can see the card when the player is connected to computer, and add files to it (but did not see the card in the player until I created Music folder, and it stopped locking up).

Media file is certainly OK as I copied it from player’s internal memory, where it is played with no problems.

Player sees the card but shows it as empty.

So, what’s wrong here? Defective item, or is reading the card content such a complex task that I missed something?

Its a card compatability with player issue.

I have a 32 gig Gskill class 10 that does not work with my 4g+ but it does work on my 8g+ and 8gzip.

I just got a 32 gig AData class 10 from Meritline today and it does work with my 4g+.

Both are legit cards. Strange issue.

The Adata works on all my players, 8g+, 4g+ and 8gzip.

The Gskil works only on my 8g+ and zip.

Go figure.

Get another card.

Side note:I own several cards that work with all my players if this helps: Adata 8g class 10, Adata 8g class 6, Transcend 8g class 6, Transcend 16g class 4, Kingston 2g, Ativa 2g [office depot brand], Sandisk 4g, Supertalent 16g class 10, Transcend 16g class 4. 


I had the issue. Here is how I fixed it:

  • choose USB transfer type “MSC” (system parameter)

  • plug you clip to PC

  • to free up space, move all music from both internal memory and SD card to a temporay folder on the PC

  • unplug Clip

  • choose USB transfer type “MTP”

  • plug clip back to PC

  • now you see clip as a MP3 player not USB drive

  • copy back you music to both internal memory and SD card as it was before

  • unplug your clip and let it list all the songs

Normally, you should see all the music now. Hope it works for you and hope it helped.

So it seems using MTP is safer than MSC.



Thanks for the input Sansamilla and dc77. Case is now solved.

Since I bought both the player and the card from the same vendor, I brought them back after the weekend, asking to let me try a different card. The manager shrugged, checked the card, didn’t see anything wrong with it, but he did see the fact that the card was unreadable to the player, so he said they would test it. Next day when I came back, he gave me a brand new player, saying that it was a defective item, that something was wrong with the card slot.

But when I plugged the card in the replaced player, I faced exactly the same problem! It would just freeze on the “Refreshing” screen. I came back yet again, and now the technician also came, brought another player and another card. And his player didn’t read my card, and my player read his card. So it was something with the card, even though computers didn’t have any problems with it. They replaced the card by another, exactly the same volume and class, and it worked. I then asked, maybe you didn’t have to replace the player at all? But they said it was defective, as it didn’t read other cards as well (or maybe the faulty card somehow killed it, though I don’t imagine how).

By resuming - it’s good that I bought the card in the same shop, otherwise I could’t have had it replaced, as any computer could read and write to it without any problems.

And this shows the value of buying where you have a return option (which I sometimes can forget about, in my haste), something which can get overlooked in searching for low prices.

Dear sirs

I have a sandisk sd card. I have formated it. Put  music on to it via i tunes. It plays on pc ok. Put in Pure evoke radio error message says sd card is empty.

Please help

Rob Burns