SD Card remains "empty"

Put in Pure evoke radio error message says sd card is empty.

 

 

= ?

And which model of Clip do you have?  Also, are the files of a format that the Clip recognizes?

I have a Clip+ 4g and a class 10 Samsung 32Gb microSD card and have exactly the same problem than FuriousBadger. It worked once and never again. The card contains mp3 files with iso-8859-1 encoded v2.3 tags. The filesystem (FAT32) on the card is utf-8 (i tried with latin1, and didn’t worked neither). The player see the card and show the free space, but not files or folders. I’m afraid that there is a compatibility issue between clip+ and samsung card. ¿does anyone have this player working with a class 10 samsung 32Gb microSD? Regards.

Try using a class 4 Sandisk card instead. Most other high quality class 4 cards will probably also work, however Sandisk players are tested with Sandisk cards, so a Sandisk class 4 card will offer maximum compatibility. the Clip+ was released before class 10 cards ever existed.

Potentially, an issue with the Class 10 card (there have been seemingly compatibility issue reports with Class 10 cards)?

Exactly the same problem here. Sansa Clip+ 4G with firmware 01.02.18P, Samsung microSD 32 GB Essential Class 10. The card works fine on all devices, also with the SD adapted in every PC I tested. h2testw didn’t find any errors. I tested different formattings (Linux, Windows, FAT32 always), also with SD Formatter 3.1 from sdcard.org. Even if the card is inserted in the connected player, I can read/write all files to the card. But the player itself doesn’t recognize any songs on it. It says the External uSD is empty, although in system settings it shows the card capacity and free values correctly.  Player is in USB MSC mode.

Now I got hands on another Sansa Clip+, this time 8GB, firmware 01.02.15P. Same behavior with this device. I’m not allowed to upgrade the firmware, though.

Solution: I installed Rockbox on my Clip+ 4G and voila: All songs from the external microSD card are detected and played properly.

This sounds like a firmware issue?

Well this is odd, i popped it into my cell phone and it was also reading empty. I popped it out of the Clip zip when it was off, turned it on and popped it back in, nothing. Take it out and back in when it’s off, nothing. I was about to go back to Rockbox but now it’s reading the card again! I could understand if it screwed up from the getgo but i had not touched it in weeks. Some of the folders have random characters at the front, not sure which device did that but it has played fine since i got it. Now that i’m back in i see some wav files i got from avsforum i believe, they were supposed to be really deep bass tracks i was going to test on my Ultrasones, i bet that’s what caused this whole ordeal. That would have really sucked as i had several albums on there which i didn’t have copies of on my computer (DOH!) Class 4 or Class whatever, it should work, all my SD cards are Sandisk for Pete’s sake! But yah from now on make sure everything is mp3 or Flac.

Random charachters in folder names probably means the player was in MTP mode when the files were transferred. Sandisk players seem to have  issues after putting files on card memory in MTP mode. One should always use MSC mode when transferring files to card memory. if you have protected files, use MTP mode to transfer them, but transfer them to main memory, not card memory.

Had the same problem manny people had, my Clip+ 4gb not finding my Samsung SD 32 GB. Installed Rockbox and it worked :slight_smile: thx for this post m8

@Diez