Clip Zip NOT recognized by the computer

My Clip Zip works on my laptop running Windows 7, but will no longer work on my PC running Windows 7. 

I’ve tried regedit and going into the device manager where I get the following message when I try and reload the software:

When trying to update the driver software for the Sansa Clip Zip using Windows 7 device manager
Windows encountered a problem installing the driver software for your device
Windows found driver software for your device, but encountered an error while attempting to install it
MTP USB device
the dependency service group failed to start

From what I have been able to find those two are the only solutions on your website.

It seems it is a problem in the registry, but I don’t know how to correct it.

Can you help?


Try turning on the player, going to settings, system settings, and change the usb mode to MSC. Try to reconnect after that. MSC mode is the  best mode to use as long as you don’t need to use protected files.

Plug the player directly(not through a hub) into a rear usb port on your pc.

I did that again , just for you. I NEED the protected files for audiobooks.

Why will it work on one PC and not another, when it did work on both?

It seems to me there is some registry problem. I tried to delete the registry files as stated on your site - but there were some I could not.

Try reinstalling the latest version of Windows Media Player. Together with the Windows Media Player are the MTP drivers.

You might be having protection issues. I don’t use protected files, however I think that the way MTP might work is that if there are any MTP transferred files on the player then the player won’t connect to a different pc in MTP mode until after those MTP transferred files are deleted. I might be wrong about all MTP files on the player causing that, and perhaps it might only happen if protected MTP transferred files are on the player. You need to do some research on how protected files and MTP mode works.

If reinstalling Windows Media Player doesn’t solve your problem, then you might have to format the player(using the player’s menu) deleting all the files on it to get it to connect to a new pc in MTP mode. If you still have the old computer you could use that to connect to the player, and use the old pc to delete the MTP transferrred files(so you won’t have to format the player) so that the player could still have the MSC transferred files remain on it.

I tried using MTP mode for a brief time a few years ago, but since then I have stuck with MSC.

By the way, just about everyone posting here is a voluntary poster. Sandisk employees typically don’t post here very much, and when they do you will see Admin or MOD next to their username. They mostly post here just to announce new firmware or new products, and usually don’t answer questions people have.

The frequent posters here try to be helpful, however I don’t know of anyone who posts frequently here who has experience using protected files. You could try doing several google searches for information about protected files, and try contacting the place you got the protected audiobooks from for advice.

Now that my Sandisk players are Rockboxed, I might not even be able to use any protected files on them(even if I boot the player in the original firmware). Rockbox is an alternative operating system(dual boot, it works alongside the original firmware, so one has the choice to boot to either one) for the player. Putting Rockbox on a player though might make it permanently unable to use protected files. Rockbox for an mp3 player is like Linux for a pc. It provides many more features and settings than the original firmware, but doesn’t support any protected files.

LOL! What do I have to gain by recommending Rockbox which is completely free???

Even though I haven’t Rockboxed my Clips (yet?), I appreciate hearing reports.   :slight_smile:

I was so against Rockbox for a long time until I got a Clip Zip and couldn’t stand its firmware. Since then I got used to Rockbox, and rarely use the original firmware. Rockbox makes the player much more customizable and more capable. Rockbox provides a great equilizer that doesn’t mess up the sound like the equilizer in the original does, and Rockbox provides crossfeed, which lets you mix part of one channel into the other so that headphone listening become much more like listening to speakers. Most recordings were made with the intention of being played on speakers, where both ears hear both channels.

Initially Rockbox seems scary due to all its settings. It is so easy to install automatically, you just need to enter the mountpoint(drive letter the pc assigned to the player). In the few months I have been using Rockbox it has been extremely stable.

I cannot find a file that will download Windows Media Center.

I find it very hard to believe that SanDisk does not have a solution for this problem. I would think that when customers get the following message when they try to fix the problem that SanDisk - just ignores the problem:

When trying to update the driver software for the Sansa Clip Zip using Windows 7 device manager
Windows encountered a problem installing the driver software for your device
Windows found driver software for your device, but encountered an error while attempting to install it
MTP USB device
the dependency service group failed to start

The only reason I bought the Clip Zip was for WMA files to download from my library.

I cannot express how much I dislike the answer that I should do “research on how protected files and MTP mode works.”

The manufacturer should do for it’s customers!

As far as I am concerned when you make a product you should support it. From what I have seen they don’t.

I believe that a lot of customers who have had this problem and only have one PC have just given up and either bought another MP3 player from SanDisk - or just given up and gone elsewhere. When their Clip Zip really still works.

But SanDisk doesn’t care it is a 50 50 chance that they will get another sale without solving the problem.

I am not a Sandisk employee. Sandisk employees don’t post here that often.  Sandisk employeees have a tag next to their username that says admin or mod.

You could try formatting the the player and deleting the files from it. It might work with the new computer in mtp mode after that.

I realize you are not a SanDisk employee maybe one of them who might go on this site, would give a sh*t about a problem that shouldn’t be a problem.

I reformatted the player - nothing happened.

You tried reinstalling Windows Media Player?

Did you try deleting the player in control panel, devices and printers, then tried reconnecting it?

Are you connecting the player first before starting Windows Media Player?

i seem to remember years ago when I tried using MTP mode, Windows Media Player gave me problems if the program was running when the player was connected, or if the player was disconnected while Windows Media Player was running.

I can’t find it in control panel - just looked again.

I cant find the player in devices and printers. No printer connected 

Did you see this page?

Yes I tried that - the error message in my original post is the result of following the directions of that solution.

SanDisk telephone numbers for Customer Support.

Do you think they can help?

Will call Monday evening.


Oh. Someone told me how to uninstall Media Player - did it and still the same result. It won’t load on the PC but will on the laptop.