Clip Zip NOT recognized by the computer

@columbuslee wrote:

Do you think they can help?



Well, ar least they can try, and it will be real-time . . . . 

The problem has been fixed!!!

While it seemed that no one here knew how to fix my Clip Zip I turned to some friends in New Zealand who were able to solve the problem.

Here is the result of their work!!!


Thanks for all your effort. I hope you can share the result with others who have had the same problem.

Here is a direct link to the solving of the problem.

I see that this is an old problem, appearantly no solved.

In my case I have 2 Zip Clips bought several years ago and one new.  (all for MP3 audiobooks only)

All three have been working just fine and came from the factory with USB mode set to auto detect.  Suddenly one of the old ones isn’t recognised by my Windows 7 computer(it still is by an old computer).

I get this message “Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)”. 

I don’t have a clue what that means or how to fix it.  I’ve tried all the USB settings.

Since the other two players are OK it seems the problem would be in the player, not the computer, but if so why is it recognised by an old XP computer?

Any new suggestions other than tossing it?


Do not throw out the mp3 player, that is just a problem with your PC.  Most likely you can fix it by going to device manager, right clicking on the mp3 player, and then choosing to uninstall.  Then plug it back in and it should reinstall.  

If it doesn’t there may be something more seriously wrong with the PC.  

Thanks, but uninstalling and reinstalling didn’t work.  The ClipZip will play audiobooks I’ve previously loaded but still isn’t recognised.

I also just discovered that the computer is no longer recognising my Passport external backup hard drive.

Looks like a job for the shop.