Clip Zip died after firmware update

I bought a Clip Zip yesterday, updated the firmware, and now it won’t power on.

  1. charged it until the battery was over 50% (per the firmware update support page)
  2. played around with it for a bit, hit the Settings page and others.  Unit seemed perfectly normal.
  3. set the usb mode to MSC
  4. downloaded the update (01.01.20), extracted clpza.bin
  5. connected the unit to my mac (os 10.6.8)
  6. copied clpza.bin to the root of the clip zip file system
  7. player showed a firmware progress bar
  8. player turned itself off (manual says it will do this after update is done)
  9. player won’t turn on.  Screen is blank.  Connecting to mac, player does not power on, charge, or establish any connection.

I searched this forum and the web, and tried:

  1. player unconnected to mac:  tried to reset by pressing down the power button for 20+ seconds
  2. player unconnected to mac:  tired to resest by pressing down power button for 20+ seconds, release, press again once
  3. pressed ‘select’ button (middle one) while connecting usb cable to computer (this supposedly can re-establish the connection to computer)
  4. left the player connected to pc overnight to see if it would charge.  Disconnected and tried steps 1 thru 3.

None of those steps worked.  Player is still dead.

Any advice on this is much appreciated.  I bought this unit to evaluate it for purchase by my students in the language class I teach, so they could each have their own player and listen to their listening comprehension assignments.  I’m not impressed so far.

So far, it looks like you followed procedure just fine. Since the “firmware upgrade” message appeared on the Zip’s display, it must have seen a valid bin firmware file.

The Clip Zip has been a reliable model, using the Austria Microsystems platform shared by several models. The only complication I see in you case is using a Mac. With this OS, you should be just fine as long as you remember that the device needs FAT32 as its base.

Now for Murphy’s Law and Electronics. If a device is going to fail, most often, it will fail early in its lifetime…or it will run trouble-free until the cows come home. The little Zip may come to life following a reset. Try holding the top power button depressed for at least 30 seconds, release, and see if it comes to life.

If it doesn’t, you might have encountered one ofthose cases of Mr. Murphy’s time proven description. The Sansa is covered bya one-year warranty (2 years in the EU) just for this reason. The simplest thing to do is exchange it for another, and your retailer can handle the details, if you just purchased the device. Otherwise, simply call Support at 1-866-SANDISK, and they’ll fix you up.

Bob  :smileyvery-happy:

Bob–thanks for your reply.  I’ll take it back and exchange it and give a new one a try.  Even though my inner nerd is tempted to keep messing with thing.