Brand New Clip Zip Not Turning On But Connects to PC

I recently acquired a 4gb Sansa Clip Zip brand new in the box. Plugged it in and refuses to charge.

Or at least so I thought. The screen never turns on but I am able to get Windows 10 to recognize the device in MSC mode. I can upload files to it no problem. I have left it to charge for a day or so, thinking maybe the battery just needed to trickle charge in order for the screen to turn on, but no luck.

I do remember the first time I connected the Zip to my PC it asked to format the drive and I foolishly formatted to fat32 with quick format. After some research, I realized I shouldn’t have quick formatted and thought maybe I accidentally removed the firmware and bricked the device. I’ve tried uploading a firmware update to the root of the drive but with the screen not functioning, I can’t tell if the update is being applied when I unplug the device.

I’ve tried doing all the reset tricks holding the power button and combination of other buttons. Still no luck.

At this point, I’m at my wits end trying to figure out what’s wrong with this new Clip Zip. Is there anyone that can help point me to a new solution I maybe haven’t tried yet? At this point I’m thinking the Zip is just broken right out the box but find that unlikely. I’m not too sure.

Any help would be appreciated.