Sansa Clip Zip Folder Not Opening in PC When Connected



Forum newbie here.


When I connected my Clip Zip to my PC this morning, my PC didn’t recognise it and open the folder as normal. The USB appears to be fine as the Clip Zip turned on by itself when connected to the PC and is currently charging.


Here’s what I have done so far:


Turned it on and off.

Reset it.

Tried downloading new firmware, but the updater states that mine is current.

Tried enabling or forcing MSC mode as per the instructions on this site but it didn’t work: the Clip Zip just turned on again as per normal.


It doesn’t show in Device Manager, either, as 1. USB Mass Storage device 
(if the player is set to MSC) 2. Portable Device (if the player is set to MTP mode) and I have changed to to each mode and auto detect to see if the DM detected it, but it still hasn’t.


This is the first time it has happened after owning it for about a year, and coincidentally, it happened after the first time I had it running all night for eigh hours (thin walls and noisy neighbours). Surely these players don’t over heat?


Can anyone suggest what I need to do to sort it out?


Thanks in advance.

This happened to me once, out of the blue, and it turns out that Windows, for unknown reasons, was trying to assign the Clip a drive that already had been allocated to a previously-installed device (and this was after the Clip previously had been able to connect to the computer just fine)–I was told that Windows just sometimes does this, to any device. The solution was to go to the Windows device manager and deauthorize the Clip drive and then to reconnect the Clip, so that Windows has to start from scratch with the Clip; or go to the Windows drive manager and give the Clip drive a new drive letter.

It sounds to me like it might be a bad cord. See if you have any friends who perhaps have a phone that uses the same cord, and ask to borrow his/hers.

Also, for future reference, if you have errors with the firmware, you should not rely on the updator. Instead, go to THIS page, and follow the “Manual Firmware Update” instructions. That will force that specific firmware to be (re)installed regaurdless of what version you have.

Very good suggestion, to try a different USB cable. Likewise, try a different USB port–at my local library a few days ago, a library computer wouldn’t recognize my flash drive, even though I had never had an issue of this type before–the situation was remedied by using a different USB port on the computer.