clip zip usb no longer working

I just got the clip zip today, managed to connect it to the usb and update firmware. when firmware update was complete, i removed the usb cord as prompted. Ever since then, I am completely unable to connect the zip clip to any computer usb. the screen of the clip just freezes solid. Nothing happens on the computers, nothing detected at all… completely dead… as if nothing was placed in the usb… i tried multiple cords, i tried changing the “usb mode” thing to all the different options… nada… anyone have any advice? I can’t do much with the thing if i cant get it connected to a computer.

Thanks, appreciate any help i get.

Try resetting it. Press and hold the power button down for 20-30 seconds (while disconnected from the computer). Release, and it should start up normally and connect to your computer again.

thanks for the response, i really appreciate it.

Every time I attempt to connect it to the computer, it freezes so the only way i can get the clip to be responsive again is by using that reset where i press down for 20-30 seconds. The clip resets but i still can never ever ever get it to connect to any computer. I’ve tried formatting the internal memory too, i’ve tried resetting to system defaults… nothing…


At this point (and on a brand-new unit) I would call SanDisk Tech Support. It may be defective. If they can’t solve the issue for you over the phone, they can arrange for a replacement to be sent to you under warranty.

1-866-SANDISK (726-3475) in the US.

Or you might get quicker service/replacement by returning it to the dealer you bought it from.